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1
Welcome to iContact for Salesforce
If you’re new to iContact for Salesforce, this guide is for you. Each chapter 
of this book walks you through the major features and helps you learn by 
doing. Later, when you’re ready and you’ve built a solid foundation on the 
basics, you can jump into some serious email marketing.

This book assumes you’ve already installed iContact for Salesforce in your org. If you haven’t, 
partner with a System Administrator and follow the Installation Guide for your org below.

Salesforce Classic
Enterprise & Unlimited

Salesforce Classic
Professional

iContact for Salesforce workflow overview
The typical iContact for Salesforce workflow is just five easy, intuitive steps.

Step 1: Create an email
Thanks to the iContact MessageBuilder and MessageCoder editors, creating email has never 
been easier. And if you already have a collection of Salesforce HTML with Letterhead 
templates, then you’re ahead of the game. Simply build a Campaign and click iContact Send.

Step 2: Create a Campaign
iContact for Salesforce sends email to Contacts and Leads who are members of a Campaign. 
Create a Campaign and choose from a variety of methods to populate it.

Step 3: Send an email to a Campaign
Whether you’re sending a test email to a handful of colleagues or a broadcast email to a few 
thousand subscribers, you start by clicking the iContact Send button on a Campaign.

https://www.icontact.com/content/resources/pdf/iContact-for-Salesforce_Classic-Enterprise-and-Unlimited-Install-Guide.pdf
https://www.icontact.com/content/resources/pdf/iContact-for-Salesforce_Classic-Enterprise-and-Unlimited-Install-Guide.pdf
https://www.icontact.com/content/resources/pdf/iContact-for-Salesforce_Classic-Professional-Install-Guide.pdf
https://www.icontact.com/content/resources/pdf/iContact-for-Salesforce_Classic-Professional-Install-Guide.pdf
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Step 4: Update statistics
iContact captures your email statistics in real time and we bring that data into your org on 
demand when you click the Update Statistics button.

Step 5: Run reports on the statistics
iContact for Salesforce comes preloaded with nearly two dozen reports and dashboards to help 
you make sense of your data, track your ROI, and drive business forward.

Supported Browsers
Chrome  and Firefox  offer the best experience with iContact for Salesforce and our 
documentation assumes you’re using one of those two browsers. The table below outlines the 
complete list of browsers that are supported by iContact for Salesforce.

Browser Details

Chrome The most recent and stable version.
Our specific recommendation.

Firefox The most recent and stable version.

Internet Explorer Versions 9, 10, and 11

Safari Versions 5.x, 6.x, and 7.x on Mac OS X Lion and before. 

Improved Setup User Interface
Unless otherwise noted, all instructions in this guide should be carried out in Salesforce. 
Furthermore, this guide assumes you’re using the Improved Setup User Interface in Salesforce. 
For the best experience following this guide, please configure your Setup Interface accordingly.

1. Log in to Salesforce.
2. Click Setup > Customize (under App Setup) > User Interface.
3. In the Setup section, check Enable Improved Setup User Interface, then click Save.

https://www.google.com/chrome/browser/desktop/
https://www.mozilla.org/en-US/firefox/new/
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2
Creating an email
With the iContact MessageBuilder and MessageCoder editors, creating 
email has never been easier. Choose from over 600 professionally- 
designed, mobile responsive email templates in MessageBuilder or design 
something amazing from the ground up with your own HTML and CSS in 
MessageCoder.

Chapters 2 and 3 were written specifically to help you build an email in iContact and copy it into 
Salesforce. If you already have a collection of Salesforce HTML with Letterhead templates, feel 
free to skip ahead to Chapter 4: Creating a Campaign.

Get started creating an email

1. Click the iContact MessageBuilder tab or log in to iContact directly . If you logged 
in to iContact directly, click Email > Messages.

2. If you want to start with one of our pre-designed templates, click Use MessageBuilder. 
If you want to write your own HTML and CSS, click Use MessageCoder.

Using MessageBuilder
The iContact MessageBuilder Editor is designed for users who prefer not to work with code. 
With iContact MessageBuilder, emails are designed using blocks and an intuitive “What You 
See Is What You Get” or WYSIWYG interface so you can visually compose a Campaign-perfect 
email in minutes.

https://www.icontact.com/login
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Selecting a template
After clicking Use MessageBuilder, the Select A Template page appears. Here you can browse 
over 600 professionally-designed templates which are conveniently organized into categories. 
Check or uncheck categories to broaden or narrow the selection of templates you see.

When you find a template you like, click the Use Template button.

Basic templates
If your tastes are subtle and more refined or if you’d like to send a text-only email, then the 
Basic template category is for you. The Basic category boasts dozens of templates that are built 
with an elegant form and structure, and none of the styling.

Note: It’s possible to build a text-only email using another iContact email creation tool, but we 
don’t recommend it. Text-only emails are, by definition, text only. They lack our embedded 
tracking pixel and traditional clickable links, which means it’s impossible for us to report on 
which Contacts or Leads opened and engaged with your email. If email statistics are 
important to you, use a Basic template.

Customizing and editing your template
After clicking the Use Template button, the Create An Email Message page appears. The page 
contains the Template Organization section, the Editor Toolbar, the Editor Window, and the 
Save section.
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Template Organization section
The Template Organization section gives you three ways to organize your templates, by Sender 
Property, Email Subject, and Message Name. 

The Sender Property is a sending profile that iContact adds to the footer of every email you 
send. Sender Properties are one of the many ways we keep you and your company compliant 
with our anti-spam policy. For more information about Sender Properties, see Sender 
Properties. For more information about our anti-spam policy, see the Anti-Spam Policy page  
on our website.

The Editor Toolbar
The Editor Toolbar is the control panel of our WYSIWYG editor. It gives you direct access to 
every design element of your email, including access to the code (in case you’re feeling 
adventurous).

Text Tab
Use the Text Tab to control the formatting and layout of your text.

Icon Description

Cut. Remove content from your email and copy it to your 
clipboard.

Copy. Copy content to your clipboard.

Paste. Add content from your clipboard to your email.

Insert link. Turn text or images into a link. Link to websites 
or anchors within your email; create Mailto links that open an 
email with a pre-populated email address, subject, and 
message; create links with iContact URL merge fields, 
including a Manage Your Subscription URL, an Opt-In URL, 
and a Web Version URL; and create Click To Call links for 
phone numbers.

Remove link. Remove a link from text or images.

https://www.icontact.com/legal/anti-spam-policy
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Anchor. Add an anchor to jump to a specific location in your 
email. 

Merge field. Add a merge field to dynamically customize an 
email for each individual Contact and Lead. For more 
information about merge fields, see Merge Fields.

Social tools. Add a Facebook Like, a Twitter Tweet, a 
Google+ +1, or a LinkedIn Share button to your email.

Strikethrough. Strikethrough text.

Subscript. Format text as subscript.

Superscript. Format text as superscript

Font size. Set the size of text.

Font. Set the font for text. 

Bold. Format text as bold.

Italic. Format text as italic.

Underline. Format text as underlined.

Font color. Set the color of text.

Numbered list. Add a numbered list to your email.

Bulleted list. Add a bulleted list to your email.

Decrease indent. Decrease the indentation of text.

Increase indent. Increase the indentation of text.

Align left. Align content to the left.

Align center. Center content.
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Align right. Align content to the right.

Justify. Justify content.

Image Tab
Use the Image Tab to add images and control their formatting and layout.

Icon Description

Insert image. Add an image to your email. For more 
information about images, see Image Library.

Border width. Set the width of an image’s border.

Border style. Set the style of an image’s border.

Border color. Set the color of an image’s border.

Wrapping style. Set the wrapping style of an image. 

Spacing position. Specify which side of an image receives 
spacing.

Spacing amount. Set the amount of spacing.

Alternative text. Set the alternative text for an image. 
Alternative stands in place of your image if your subscriber’s 
inbox is set not to display images. It can also be read by 
screen readers to enhance accessibility.

Warning: Image borders, border styles, border colors, wrapping, and spacing are not fully 
supported by all inboxes. For more information about which style options are supported by 
popular inboxes, check out the Email Standards Project .

https://email-standards.org/
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Block Tab
A block is a container that can hold text, images, and links. Use the Block Tab to control the 
formatting and layout of your blocks.

Icon Description

Background color. Set the background color of a block.

Border edge. Specify which side of a block receives a 
border.

Border width. Set the width of a block’s border.

Border style. Set the style of a block’s border.

Border color. Set the color of a block’s border.

Spacing position. Specify which side of a block receives 
spacing.

Spacing amount. Set the amount of spacing.

HTML. Make changes directly to a block’s HTML and inline 
CSS.

Warning: Block borders, border styles, border colors, and spacing are not fully supported by 
all inboxes. For more information about which style options are supported by popular inboxes, 
check out the Email Standards Project .

Section Tab
A section is a container that can hold blocks. Use the Section Tab to control the formatting and 
layout of your sections.

https://email-standards.org/
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Icon Description

Background color. Set the background color of a section.

Border edge. Specify which side of a section receives a 
border.

Border width. Set the width of a section’s border.

Border style. Set the style of a section’s border.

Border color. Set the color of a section’s border.

Spacing position. Specify which side of a section receives 
spacing.

Spacing amount. Set the amount of spacing.

Warning: Section borders, border styles, border colors, and spacing are not fully supported 
by all inboxes. For more information about which style options are supported by popular 
inboxes, check out the Email Standards Project .

Message Tab
Use the Message Tab to control the formatting and layout of your email, to run spell check and 
spam check, and to send Test Emails to yourself or a colleague.

Icon Description

Background color. Set the background color of the email.

Border edge. Specify which side of the email receives a 
border.

https://email-standards.org/
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Border width. Set the width of the email’s border.

Border style. Set the style of the email’s border.

Border color. Set the color of the email’s border.

Spacing position. Specify which side of the email receives 
spacing.

Spacing amount. Set the amount of spacing.

Spell check. Run spell check.

Spam check. Run spam check. For more information about 
spam scoring, see Spam check.

Send Test Message. Send a test email to review the design 
of your email in your inbox.

Preview pop-up. Preview your email on various screen 
widths.

Source code. Make changes directly to a email’s HTML and 
CSS.

Warning: Message borders, border styles, border colors, and spacing are not fully supported 
by all inboxes. For more information about which style options are supported by popular 
inboxes, check out the Email Standards Project .

Save section
By clicking the Save As Draft button, you can save your work and return to it later.

You can also use the Custom Templates section to turn your email into a reusable template that 
you can find on the Select A Template page. To save your email as a reusable template, give it 
a name, then click the Save button.

Warning: Do not click the Proceed To Send button. Clicking the Proceed To Send button will 
send your email directly from iContact, bypassing iContact for Salesforce. If you send an 
email directly from iContact, your email will live in iContact. You will never see a record of it in 

https://email-standards.org/
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Salesforce and you will never be able to see its statistics in Salesforce.

Using MessageCoder
The iContact MessageCoder Editor is designed for professional graphic designers and 
developers. With a blank canvas and direct access to the HTML and CSS of your email, you’ll 
feel right at home.

To get started, click Use MessageCoder.

After clicking Use MessageCoder, the Create An Email Message page appears. The page 
contains the Template Organization section, the Editor Toolbar, the Editor Window, and the 
Save section.

Template Organization section
The Template Organization section gives you three ways to organize your templates, by Sender 
Property, Email Subject, and Message Name. 

The Sender Property is a sending profile that iContact adds to the footer of every email you 
send. Sender Properties are one of the many ways we keep you and your company compliant 
with our anti-spam policy. For more information about Sender Properties, see Sender 
Properties. For more information about our anti-spam policy, see the Anti-Spam Policy page  
on our website.

The Editor Toolbar
The Editor Toolbar is the control panel of our WYSIWYG editor. It gives you direct access to 
every design element of your email, including unobstructed access to the code.

https://www.icontact.com/legal/anti-spam-policy


15

Text Tab
Use the Text Tab to control the formatting and layout of your text.

Icon Description

Cut. Remove content from your email and copy it to your 
clipboard.

Copy. Copy content to your clipboard.

Paste. Add content from your clipboard to your email.

Insert link. Turn text or images into a link. Link to websites 
or anchors within your email; create Mailto links that open an 
email with a pre-populated email address, subject, and 
message; create links with iContact URL merge fields, 
including a Manage Your Subscription URL, an Opt-In URL, 
and a Web Version URL; and create Click To Call links for 
phone numbers.

Remove link. Remove a link from text or images.

Anchor. Add an anchor to jump to a specific location in your 
email. 

Social tools. Add a Facebook Like, a Twitter Tweet, a 
Google+ +1, or a LinkedIn Share button for your email.

Strikethrough. Strikethrough text.

Subscript. Format text as subscript.

Superscript. Format text as superscript

Font size. Set the size of text.
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Font. Set the font for text. 

Bold. Format text as bold.

Italic. Format text as italic.

Underline. Format text as underlined.

Font color. Set the color of text.

Numbered list. Add a numbered list to your email.

Bulleted list. Add a bulleted list to your email.

Decrease indent. Decrease the indentation of text.

Increase indent. Increase the indentation of text.

Align left. Align content to the left.

Align center. Center content.

Align right. Align content to the right.

Justify. Justify content.

Insert table. Add a table to your email.

Insert horizontal rule. Add a horizontal rule to your email.

Insert special character. Add a special character to your 
email.

Image Tab
Use the Image Tab to add images and control their formatting and layout.
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Icon Description

Insert image. Add an image to your email. For more 
information about images, see Image Library.

Image width. Set the width of an image.

Image height. Set the height of an image.

Border width. Set the width of an image’s border.

Border style. Set the style of an image’s border.

Border color. Set the color of an image’s border.

Wrapping style. Set the wrapping style of an image. 

Spacing position. Specify which side of an image receives 
spacing.

Spacing amount. Set the amount of spacing.

Alternative text. Set the alternative text for an image. 
Alternative stands in place of your image if your subscriber’s 
inbox is set not to display images. It can also be read by 
screen readers to enhance accessibility.

Warning: Image borders, border styles, border colors, wrapping, and spacing are not fully 
supported by all inboxes. For more information about which style options are supported by 
popular inboxes, check out the Email Standards Project .

Message Tab
Use the Message Tab to control the formatting and layout of your email, to run spell check and 
spam check, and to send Test Emails to yourself or a colleague.

Icon Description

https://email-standards.org/
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Design mode. Enter a WYSIWYG view to see the rendered 
design of your HTML and CSS. 

HTML mode. Enter a code view to see the HTML and CSS 
behind your design.

Preview pop-up. Preview your email on various screen 
widths.

Spell check. Run spell check.

Spam check. Run spam check. For more information about 
spam scoring, see Spam check.

Send Test Message. Send a test email to review the design 
of your email in your inbox.

Word wrap. Turn on or turn off the line wrapping for your 
code.

Line numbers. Turn on or turn off the line numbers for your 
code.

Save section
By clicking the Save As Draft button, you can save your work and return to it later.

Warning: Do not click the Proceed To Send button. Clicking the Proceed To Send button will 
send your email directly from iContact, bypassing iContact for Salesforce. If you send an 
email directly from iContact, your email will live in iContact. You will never see a record of it in 
Salesforce and you will never be able to see its statistics in Salesforce.

iContact Design Services
For an additional fee, the iContact Design Services team is available if you’re interested in 
something custom that was designed just for you and your business. They’re also your best 
resource if you’re running into trouble making big changes to your template, changes like adding 
or moving sections or columns, or customizing the code you built.

iContact Design Services can be reached by email at designservices@icontact.com. iContact 
Design Services hours are Monday - Friday, 8 a.m. - 6 p.m. EST.

mailto:designservices@icontact.com
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3
Copying an email from iContact into 
Salesforce
You just designed the perfect email in iContact. Now, copy the email into 
Salesforce so you can send it to your Campaign Members.

This chapter was written specifically to help you copy an email from iContact into Salesforce. If 
you already have a collection of Salesforce HTML with Letterhead templates, feel free to skip 
ahead to Chapter 4: Creating a Campaign.

Copy your email’s code in iContact

1. Click the Message tab on the editor toolbar. If you’re using MessageBuilder, continue 
with Steps 2 and 3 below. If you’re using MessageCoder, jump down and follow Steps 4 
and 5.

2. Click the Source button in the Advanced section, then click Continue.
3. Select all the code and copy it to your clipboard, then click Close. Skip the next two 

steps and continue with the instructions below.
4. Click the HTML button in the Editor Style section.
5. Select all the code and copy it to your clipboard.

Paste your email’s code into Salesforce

1. Click Setup > Communication Templates (under Administer) > Email Templates.
2. Click the New Template button.
3. Select Custom (without using Letterhead), then click Next.
4. Decide which folder to save the template in (we recommend the iContact Templates 

folder), check Available For Use, and give the template a name and unique name, then 
click Next.
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Note: The Available For Use box isn’t required by Salesforce, but it is required by iContact for 
Salesforce. If an email isn’t made available, then it can’t be sent with iContact for Salesforce.

5. Give the template a subject. This is the subject your subscribers will see when you send 
the email.

6. Paste the code into the HTML Body box, then click Next.
7. Click the Copy Text From HTML Version button, confirm that you want to copy text, 

then click Save.

Avoid the Send Test And Verify Merge Fields button
The Send Test And Verify Merge Fields button is a Salesforce button that operates outside of 
iContact for Salesforce. Sending a test email using this button will send the email from 
Salesforce servers, not iContact for Salesforce servers, and may result in unexpected design, 
formatting, or deliverability issues.

Always test email by clicking the iContact Send button on a Campaign. For more information 
about sending email, see Chapter 6: Sending email.
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4
Creating a Campaign
Campaigns are the hubs for iContact for Salesforce. They’re where you 
manage Campaign Members, send email, update statistics, and more.

Create a Campaign

1. Click the Campaigns tab.
2. Click the New button.
3. If Salesforce asks which record type you’d like to use, select the iContact for 

Salesforce record type, then click Continue. If Salesforce doesn’t ask, skip this step.
4. Give the Campaign a name, then click Save. 

The Campaign Name is the only required field to create and save a Campaign. There are many 
other fields associated with the iContact for Salesforce record type (outlined in the table below) 
that you can use when creating a Campaign.

Campaign page overview
If you want to get the most out of Campaigns, then it’s important to understand the fields that 
make up standard Campaign pages.
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Salesforce Campaign fields
The following table lists Salesforce Campaign fields that are associated with the iContact for 
Salesforce record type. Depending on your page layout and field-level security settings, some 
fields may not be visible or editable. Unless otherwise noted, these fields are not accessible by 
iContact for Salesforce. You must update them manually.

Field Description

Active A checkbox to mark whether the Campaign is active or not. 
Unlike the Active box for emails, this box is not required by 
iContact for Salesforce.

Actual Cost The amount of money spent to run the Campaign.

Budgeted Cost The amount of money budgeted for the Campaign.

Campaign Name The identifying name for the Campaign.

Campaign Owner The assigned owner of the Campaign.

Campaign Record Type The record type for the campaign. It determines the picklist 
values, the buttons, and the related lists available for the 
campaign. You should always use the iContact for 
Salesforce Campaign record type.

Converted Leads The number of Leads that were converted to Accounts due 
to the marketing efforts in the Campaign. Salesforce 
automatically calculates this amount using all associated 
records regardless of whether you have read access to 
them. For more information about converting Leads, see 
Convert Qualified Leads .

Description The description of the Campaign. Up to 32KB of data are 
allowed in this field. Only the first 255 characters display in 
reports.

End Date The ending date for the Campaign. Responses received 
after this date are still counted.

Expected Response (%) The percentage of responses you expect to receive for the 
Campaign.

Expected Revenue The amount of money you expect to generate from the 
Campaign.

https://help.salesforce.com/apex/HTViewHelpDoc?id=leads_convert.htm&language=en_US
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Last Update Date The date and time of the last time statistics were updated for 
the Campaign. This field is accessible to iContact for 
Salesforce and is updated automatically.

Message Statistic Count The total number of emails with a status of “Released” that 
were used to calculate the Open, Click, Bounce, and 
Unsubscribe rate averages for the Campaign. This field is 
accessible to iContact for Salesforce and is updated 
automatically.

Num Total Opportunities The number of Opportunities associated with the Campaign. 
This field is read only. Salesforce automatically calculates 
this amount using all associated records regardless of 
whether you have read access to them.

Num Sent The number of individuals targeted by the Campaign.

Num Won Opportunities The number of closed/won Opportunities associated with the 
Campaign. This field is read only. Salesforce automatically 
calculates this amount using all associated records 
regardless of whether you have read access to them.

Parent Campaign The Campaign above the selected Campaign in the 
Campaign hierarchy.

Start Date The starting date for the Campaign.

Status The status of the campaign. The default values may be 
edited by an administrator.

Total Contacts The number of individuals on Accounts who are associated 
with the Campaign. Salesforce automatically calculates this 
amount using all associated records regardless of whether 
you have read access to them.

Total Leads The number of Leads associated with the Campaign. 
Salesforce automatically calculates this amount using all 
associated records regardless of whether you have read 
access to them.

Total Responses The total number of Contacts and unconverted Leads who 
have a Member Status equivalent to “Responded” for the 
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Campaign. This field is read only. Salesforce automatically 
calculates this amount using all associated records 
regardless of whether you have read access to them. 

Total Value Opportunities The amount of all Opportunities associated with the 
Campaign, including closed/won Opportunities. This field is 
read only. Salesforce automatically calculates this amount 
using all associated records regardless of whether you have 
read access to them.

Total Value Won Opportunities The amount of all closed/won Opportunities associated with 
the Campaign. This field is read only. Salesforce 
automatically calculates this amount using all associated 
records regardless of whether you have read access to 
them.

Type The type of Campaign, for example, Email or Referral 
Program. The default values may be edited by an 
administrator.

For more information about Salesforce Campaign fields, including a complete list of available 
fields, see Campaign Fields  in the Salesforce Success Community.

Charts
The charts are a visual representation of the averages of the Open, Click, Bounce, and 
Unsubscribe rates for all emails in the Campaign with a status of Released.

https://help.salesforce.com/apex/HTViewHelpDoc?id=campaigns_fields.htm&language=en
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iContact for Salesforce Campaign fields
The following table lists iContact Campaign fields that are associated with the iContact for 
Salesforce record type. When you have a better understanding of how your emails perform, feel 
free to update the default values set for these targets.

Field Description

Average Bounce Rate The average bounce rate of all emails in the Campaign with 
a status of Released.

Average Click Rate The average click rate of all emails in the Campaign with a 
status of Released.

Average Open Rate The average open rate of all emails in the Campaign with a 
status of Released.

Average Unsubscribe Rate The average unsubscribe rate of all emails in the Campaign 
with a status of Released.

Bounce Rate Caution % The first threshold where the Bounce Rate gauge transitions 
from green and becomes yellow. The default value is 1%.

Bounce Rate Warning % The second threshold where the Bounce Rate gauge 
transitions from yellow and becomes red. The default value 
is 3%.

Click Rate Caution % The first threshold where the Click Rate gauge transitions 
from red and becomes yellow. The default value is 1%.

Click Rate Success % The second threshold where the Click Rate gauge 
transitions from yellow and becomes green. The default 
value is 8%.

Open Rate Caution % The first threshold where the Open Rate gauge transitions 
from red and becomes yellow. The default value is 5%.
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Open Rate Success % The second threshold where the Open Rate gauge 
transitions from yellow and becomes green. The default 
value is 10%.

Unsubscribe Rate Caution % The first threshold where the Unsubscribe Rate gauge 
transitions from green and becomes yellow. The default 
value is 0.1%.

Unsubscribe Rate Warning % The second threshold where the Unsubscribe Rate gauge 
transitions from yellow and becomes red. The default value 
is 1%.

iContact Sent Messages related list
The iContact Sent Messages related list is where you find a list of all emails sent to your 
Campaign, including key email statistics data.

Column Description

Action Allows you to perform advanced actions on the email or to 
delete the record from the list.

Message Subject Displays the subject of the email. Click this link to view the 
iContact Sent Message Detail page for the email.

Scheduled Time The date and time the email was scheduled for release. 
Emails scheduled for immediate delivery record the date and 
time at the time of the send.

Unique Opens A running tally of the number of subscribers who opened the 
email. Subscribers who open the email more than once will 
record just one unique open.

Total Opens A running tally of the total number of times the email was 
opened.

Unique Clicks A running tally of the number of subscribers who clicked a 
link in the email. Subscribers who click a link more than once 
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or who click more than one link will record just one unique 
click.

Total Clicks A running tally of the total number of times links were clicked 
in the email.

Delivered The number of emails that were successfully delivered to 
Campaign Members. For more information about why this 
number may be lower than expected, see Why doesn’t 
iContact send email to all Campaign Members?

Unsubscribes A running tally of the number of subscribers who 
unsubscribed from the email.

Targeted A checkbox that shows whether or not the email was a 
Targeted Send.

Status Displays the status of the email: Scheduled, In Progress, 
Released, or Error.

Scheduled. The email is scheduled for release.
In Progress. The email is in the process of being released.
Released. The email was released.
Error. There was a problem and the email was not released.
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5
Adding Campaign Members
iContact for Salesforce can send email to Contacts and Leads who are 
members of a Campaign. Salesforce is flexible and offers many ways to 
populate Campaigns.

Using the Manage Members button
The Manage Members button is the easiest way to add Campaign Members directly from the 
page of any Campaign.

Add Campaign Members using the Manage Members button

1. Click the Campaigns tab.
2. Click the Campaign you want to add Members to.
3. Click the Manage Members button > Add Members - Search.
4. Select which member type to search, either Contacts or Leads.
5. Define your filter criteria, then click the Go button.
6. Check the box next to the name or names you want to add, then click the Add With 

Status button > Sent.

Note: When using the Manage Members button, Salesforce allows you to add Campaign 
Members in batches of up to 200 people.
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Adding Campaign Members from a report
Adding Campaign Members from a report is the most powerful way to populate your 
Campaigns. With Salesforce’s robust reporting tools, you can drill down to your target 
Campaign Members in just a few clicks.

Add Campaign Members by running a report

1. Click the Reports tab.
2. Click the New Report button.
3. Open the Accounts & Contacts or Leads folder > Contacts & Accounts or Leads > 

Create button.
4. Drill down to your target Contacts or Leads by using the Filters options, then click the 

Run Report button.
5. Click the Add To Campaign button > Magnifying Glass icon. Select a Campaign from 

the pick list.
6. Click the Add To Campaign button, then click Done.

Note: When adding Campaign Members by running a report, Salesforce allows you to add 
Campaign Members in batches of up to 50,000 people.

Salesforce only supports the Add To Campaign button on standard Account And Contact, 
Opportunities And Roles, Cases And Roles, and Lead reports. Salesforce does not support 
the Add To Campaign button on reports that include Custom Objects like the iContact 
Message Statistics object, nor does it support the button on reports that contain both 
Contacts and Leads.

If you run a report that doesn’t support the Add To Campaign button, customize the report 
to include the Lead/Contact ID and Email fields, export the report to a .csv, then import it to 
your Campaign using the steps outlined in the Uploading Campaign Members from a .csv 
using the Data Import Wizard section below.

For more information about running reports in Salesforce, see Reports and Dashboards  in 
the Salesforce Success Community.

https://help.salesforce.com/HTViewQuickStarts?id=000113375
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Adding Campaign Members from the Contacts or Leads page
If your workflow frequently brings you to the Contacts or Leads page, use the Add To Campaign 
button to quickly add subscribers to your Campaigns.

Add Campaign Members using the Add To Campaign button on the Contacts or Leads 
page

1. Click the Contacts or Leads tab.
2. Select a view from the View dropdown.
3. Check the box next to the name or names you want to add, then click the Add To 

Campaign button.
4. Click the Magnifying Glass icon and select a Campaign from the pick list.
5. Click the Add To Campaign button, then click Done.

Note: When adding Campaign Members from the Contacts or Leads page, Salesforce allows 
you to add Campaign Members in batches of up to 200 people.

Uploading Campaign Members from a .csv using the Data Import Wizard
The Data Import Wizard makes it easy to add Campaign Members from a .csv by uploading the 
file directly to a Campaign. Salesforce will even create new Contact or Lead records for 
individuals who aren’t already saved in your org.

Add Campaign Members by uploading a .csv file to a Campaign

1. Click the Campaigns tab.
2. Click the Campaign you want to add Members to.
3. Click the Manage Members button > Add Members - Import File.
4. Follow the steps listed in the Data Import Wizard. Salesforce will send you an email 

when the upload is completed.

Warning: Salesforce will create a new Contact or Lead record for any individual uploaded 
without a Salesforce.com ID. In order to prevent duplicates in your org, do not upload 
Contacts or Leads who are already a part of your database without including their 
Salesforce.com ID in the upload file.

For more information about using the Data Import Wizard, see Salesforce’s Data Import

http://salesforce.vidyard.com/watch/ARIjWm2qrDkJVJxEhReFug
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Series . For more information about importing Campaign Members, see Importing Campaign 
Members  in the Salesforce Success Community.

http://salesforce.vidyard.com/watch/ARIjWm2qrDkJVJxEhReFug
https://help.salesforce.com/HTViewHelpDoc?id=campaigns_import.htm&language=en_US
https://help.salesforce.com/HTViewHelpDoc?id=campaigns_import.htm&language=en_US
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6
Sending email
Whether you’re sending a test email to a handful of colleagues or a 
broadcast email to a few thousand subscribers, you start by clicking the 
iContact Send button on a Campaign.

Up until now, everything we’ve covered has been 100% iContact or Salesforce. Now, without 
further ado, iContact for Salesforce.

How to send email

1. Click the Campaigns tab.
2. Click the Campaign you want to send an email to.
3. Click the iContact Send button.
4. Give your browser permission to load mixed content.

○ If you’re using Chrome
1. Click the gray shield on the right side of the URL bar.
2. Click Load unsafe scripts.

○ If you’re using Firefox
1. Click the green lock on the left side of the URL bar.
2. Click the arrow on the right side of the pop-up, then click Disable 

Protection For Now.

Note: If you don’t see a gray shield in Chrome or a green lock in Firefox, your browser is not 
blocking mixed content. For more information about mixed content, see Mixed content.

5. In the Select Email Template section, select the folder that contains the email you want 
to send, then select the email itself. iContact for Salesforce will search your email for 
merge fields and attempt to validate them if any are found. For more information about 

https://docs.google.com/document/d/1zhaUawHvlzYdpkLjpgtDhivZPvhq0YS2aMbwrydCF8s/edit#bookmark=kix.m0nditt3uf43
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using merge fields, see Merge fields. If iContact for Salesforce is unable to validate 
merge fields, see Unable to validate merge fields.

Notification Explanation

This template has no merge 
fields.

No merge fields were found in your email.

This template’s merge fields 
are supported.

Merge fields were found in your email and they pass 
validation. As long as you’re using the correct merge fields 
for your Campaign Members and your Campaign Members 
have data to merge, the merge fields will work.

Unsupported merge fields 
detected. The unsupported 
fields have been highlighted in 
the preview below.

iContact for Salesforce found merge fields in your email but 
they do not pass validation. Do not send an email with 
unsupported merge fields. They will not work. Confirm the 
syntax of your merge fields and test them by sending a test 
email to your iContact for Salesforce Test Campaign.

 
6. In the Sending Options section, select a Sender Property (also called a From Option). 

Sender Properties are one of the many ways we keep you and your company compliant 
with our anti-spam policy. For more information about Sender Properties, see Sender 
Properties. For more information about our anti-spam policy, see the Anti-Spam Policy 
page  on our website.

7. In the Version section, check the box if you want to track email statistics for your 
subscribers. Uncheck the box if you don’t want to track email statistics.

8. In the Accept Terms And Conditions section, type your initials to certify you have the 
right to send email to your subscribers.

9. Click the Send To Campaign Members button at either the top or bottom of the page.
10. Review the email’s Spam Score, then click the Continue button. For more information 

about how spam scores are determined for your emails, see Spam check.

iContact Sent Message Detail
After clicking the Continue button, you’ll be directed to the iContact Sent Message Detail page. 
The iContact Sent Message Detail page houses myriad data for your email, ranging from 
release data to email statistics to the spam score.

There is also a Status field in the Message Properties section where the progress of your email 
is updated in real time. The table below explains the status designations.

Status Explanation

https://www.icontact.com/legal/anti-spam-policy
https://www.icontact.com/legal/anti-spam-policy
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Scheduled iContact sends email on a first-come-first-served basis from 
a queue. So whether an email is to be sent immediately or 
scheduled for a future date and time, its status begins as 
Scheduled.

In Progress When Salesforce begins transferring data from your org to 
iContact, the email’s status will update to In Progress. If you 
ever need to cancel an email, you must cancel it by clicking 
the Cancel Send button on the iContact Sent Message 
Detail page before the status is updated to In Progress. For 
more information about canceling email, see Chapter 8: 
Canceling email.

Released When iContact completes the send process, the email’s 
status will update to Released. At that point, the Update 
Statistics button becomes active and you may update 
statistics. For more information about updating statistics, see 
Chapter 9: Updating statistics.

Sender Properties
A Sender Property is a sending profile that iContact adds to the footer of every email you send. 
Sender Properties are one of the many ways we keep you and your company compliant with our 
anti-spam policy. For more information about our anti-spam policy, see the Anti-Spam Policy 
page  on our website.

Create Sender Properties in iContact

1. Click the iContact MessageBuilder tab or log in to iContact directly .
2. Click the Account Drop Down > Sender Properties > Create A New Sender 

Property. The Account drop down displays your name or a colleague’s name. 
3. Complete the required fields at the top of the page and the address fields in the middle 

of the page, then click the Save button.

Create Sender Properties in Salesforce
Before sending an email to a Campaign, you may create a new Sender Property on the fly on 
the Send iContact Message page.

1. Click the Campaigns tab.
2. Click the Campaign you want to send an email to.
3. Click the iContact Send button.
4. In the Sending Options section, select New from the From Option dropdown.

https://www.icontact.com/legal/anti-spam-policy
https://www.icontact.com/legal/anti-spam-policy
https://www.icontact.com/login


35

5. Complete the required fields of the Sending Options section with the information for the 
new Sender Property.

6. When you’re ready to send the email, click the Send To Campaign Members button.

Warning: Do not click the Create button in the Sending Options section. It will not create your 
new Sender Property. Clicking the button will only delete the text you entered in the other 
fields, requiring you to fill them out again.

The anatomy of a Sender Property
Sender Properties are comprised of 4 elements, the From Name, the name of the individual or 
organization sending the email; the From Email Address, the individual’s or organization’s email 
address; the Company, the company the individual or organization belongs to; and the Physical 
Address, the company’s address.

Sender Property syntax
From Name | From Email Address | Company | Physical Address | Physical Address

Example Sender Property for iContact for Salesforce Support
iContact for Salesforce Support | salesforce@icontact.com | iContact | 2121 RDU Center Drive | 
Morrisville, NC 27560

The following table maps specific iContact and iContact for Salesforce fields that populate the 
elements of a Sender Property:

Element iContact iContact for Salesforce

From Name From Name field on the Edit A 
Sender Property page in your 
bundled iContact account.

From Name field in the Sending 
Options section on the Send 
iContact Message page.

From Email Address From Email Address field on the 
Edit A Sender Property page in 
your bundled iContact account.

From Email field in the Sending 
Options section on the Send 
iContact Message page.

Company Company field on the Edit A 
Sender Property page in your 
bundled iContact account.

Company field on the Edit A 
Sender Property page in your 
bundled iContact account.

Physical Address Address fields in the CAN-SPAM 
Compliance Requirements 
section on the Edit A Sender 

Address fields in the Sending 
Options section on the Send 
iContact Message page.
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Property page in your bundled 
iContact account.

Note: By default, Sender Properties format addresses according to the US format. Contact 
iContact for Salesforce Support if you’re not located in the US and need a format for your 
country. 

iContact for Salesforce Support can be reached at 1 (866) 331-3208, internationally at
+1 (919) 926-4234, or via email at salesforce@icontact.com. We’re available Monday – 
Friday, 9 a.m. – 6 p.m. Eastern Time.

Spam check
iContact is partnered with SpamAssassin , a leading anti-spam organization that vets every 
email sent from our platform. SpamAssassin uses a robust scoring framework to 
comprehensively evaluate the likelihood of your message going to spam based on your email 
headers, subject line, body, links, and domain.

Emails are scored on a scale from 0.0 - 8.0, with 0.0 being the target score.

If an email is rated with a 4.9 score or lower, we believe it stands a great chance of hitting your 
subscribers’ inbox, so we’ll allow you to send it. If an email is rated with a 5.0 score or higher, 
you must review the points counting against it and improve it before it can be sent.

SpamAssassin has a roundup of point names and descriptions  you can use to reduce your 
spam score and improve an email.

mailto:salesforce@icontact.com
http://spamassassin.apache.org/
https://spamassassin.apache.org/tests_3_3_x.html
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7
Scheduling email
iContact for Salesforce gives you the flexibility to draft your emails today 
and send them tomorrow (or any other time that’s more convenient).

How to schedule email

1. Click the Campaigns tab.
2. Click the Campaign you want to send an email to.
3. Click the iContact Send button.
4. Follow the instructions outlined in Chapter 6: Sending email: 

○ Give your browser permission to load mixed content.
○ Select the email you want to send.
○ Select a Sender Property.
○ Decide whether or not you want to store email statistics for your subscribers.
○ Type your initials to certify you have the right to send email to your subscribers.

5. In the Scheduling section, click Send Later.
6. Use the Date Field Pop-up Calendar to select the date and time of the send, then click 

the Send To Campaign Members button.

The most important thing to know about scheduling email
If you need to make changes of any kind to the email (changing the date or time of the send, 
updating the subject line, fixing a typo, adding or removing Campaign Members, anything), you 
must first click the Cancel Send button on the iContact Sent Message Detail page. Do not click 
the Delete button. Deleting an email will not cancel the email. If you do not click the Cancel 
Send button, the original email will be sent at the originally-scheduled date and time to the 
original group of Campaign Members. 

This is so important, we’re going to say it again.
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If you need to make changes of any kind to the email (changing the date or time of the 
send, updating the subject line, fixing a typo, adding or removing Campaign Members, 
anything), you must first click the Cancel Send button on the iContact Sent Message 
Detail page. Do not click the Delete button. Deleting an email will not cancel the email. If 
you do not click the Cancel Send button, the original email will be sent at the originally-
scheduled date and time to the original group of Campaign Members. 

For more information about canceling email, see Chapter 8: Canceling email.
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8
Canceling email
We all make mistakes. At one point or another, you’ll need to cancel an 
email. There’s only one way to cancel an email and knowing how to do it is 
so important, we gave it its own chapter.

How to cancel email

1. Click the Campaigns tab.
2. Click the Campaign that contains the email you need to cancel.
3. Click the iContact Sent Messages link > click the name of the email you need to 

cancel.
4. Click the Cancel Send button.

If the email is too far along in the sending process

Error: This email send can not be canceled. The email is too far along in the sending process 
to be canceled.

If you’re unable to cancel the email because it’s too far along in the sending process, then the 
sending process has already begun. Follow these steps to attempt to cancel it from your 
bundled iContact account.  

1. Click the iContact MessageBuilder tab or log in to iContact directly .
2. Click Email > Pending Messages > Cancel This Message.

The most important thing to know about canceling email
If you need to cancel an email for any reason (it was scheduled with the wrong date or time, you 
need to update the subject line or fix a typo, you need to add or remove Campaign Members, 
you decided against sending the email at all, anything), you must first click the Cancel Send 
button on the iContact Sent Message Detail page. Do not click the Delete button. Deleting an 

https://www.icontact.com/login
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email will not cancel the email. If you do not click the Cancel Send button, the original email will 
be sent at the originally-scheduled date and time to the original group of Campaign Members. 

This is so important, we’re going to say it again.

If you need to cancel an email for any reason (it was scheduled with the wrong date or 
time, you need to update the subject line or fix a typo, you need to add or remove 
Campaign Members, you decided against sending the email at all, anything), you must 
first click the Cancel Send button on the iContact Sent Message Detail page. Do not click 
the Delete button. Deleting an email will not cancel the email. If you do not click the 
Cancel Send button, the original email will be sent at the originally-scheduled date and 
time to the original group of Campaign Members.

Why doesn’t the Delete button work?
Salesforce and iContact communicate through an API. Some of the things you do in Salesforce 
trigger communication through the API, things like sending email, updating statistics, and 
canceling email. These kinds of actions require Salesforce and iContact to work together to 
complete a task. Other things that don’t require Salesforce and iContact to work together -- 
things that can be accomplished in Salesforce without iContact -- don’t trigger communication 
through the API, things like adding Campaign Members, running reports, and deleting emails.

Because deleting an email doesn’t trigger communication through the API, iContact is left 
unaware of the fact that your email was deleted. So when the time comes to send the email, 
iContact carries out the last set of instructions it received from Salesforce: Send this email at 
this date and time to this group of people.
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9
Updating statistics
iContact captures your email statistics in real time and we bring that data 
into your org on demand when you click the Update Statistics button.

Update statistics for Campaigns
The easiest way to update statistics for every email ever sent to a Campaign is to click the 
Update Statistics button on the Campaign page.

1. Click the Campaigns tab.
2. Click the Campaign you want to update.
3. Click the Update Statistics button. A pop-up window will appear showing you the 

progress of the update.
4. When the update completes, refresh the page.

Note: Depending on the number of emails in the Campaign, it may take several minutes to 
update statistics.

Update statistics for specific emails
If you’re interested in the statistics for a specific email, click the Update Statistics button on the 
iContact Sent Message Detail page for that email.

1. Click the Campaigns tab.
2. Click the Campaign that contains the email you want to update.
3. Click the iContact Sent Messages link.
4. Click the email you want to update.
5. Click the Update Statistics button.
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10
Sending a Targeted Send
The perfect follow-up email -- one that’s timely and ultra relevant to a 
specific subgroup of your Campaign -- is just a few clicks away.

Clicking the Targeted Send button on a Campaign lets you send a follow-up email based on 
criteria related to the Campaign’s Campaign Members and the previous emails sent to that 
Campaign. Clicking the Targeted Send button on a specific email lets you send a follow-up 
email based on criteria that is unique to that specific email.

Send a Targeted Send to a Campaign

1. Click the Campaigns tab.
2. Click the Campaign you want to send a Targeted Send to.
3. Click the Update Statistics button. For more information about updating statistics, see 

Chapter 9: Updating statistics.
4. Click the Targeted Send button.
5. Select your Targeted Send criteria, then click Next:

○ Send only to subscribers who opened a specific email.
○ Send only to subscribers who opened but did not click on a specific email.
○ Send only to subscribers who did not open a specific email.
○ Send only to subscribers who clicked a specific link in a specific email, a 

selection of links in the email, or any link in the email.
○ Send only to subscribers who were added to the Campaign on or before a 

specific date, on or after a specific date, or between two dates.
○ Send only to subscribers who have not received an email from the Campaign.
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6. Proceed with the regular sending method. Follow the instructions outlined in Chapter 6: 
Sending email:

○ Give your browser permission to load mixed content.
○ Select the email you want to send.
○ Select a Sender Property.
○ Decide whether or not you want to store email statistics for your subscribers.
○ Type your initials to certify you have the right to send email to your subscribers.
○ Decide whether to send this email immediately or to schedule it for later.
○ Click the Send to Campaign Members button.

Send a Targeted Send to an email

1. Click the Campaigns tab.
2. Click the Campaign that contains the email you want to send a Targeted Send to.
3. Click the iContact Sent Messages link.
4. Click the email you want to send a Targeted Send to.
5. Click the Update Statistics button. For more information about updating statistics, see 

Chapter 9: Updating statistics.
6. Click the Targeted Send button.
7. Select your Targeted Send criteria, then click Next:

○ Send only to subscribers who opened the email.
○ Send only to subscribers who opened but did not click on the email.
○ Send only to subscribers who did not open the email.
○ Send only to subscribers who clicked a specific link in the email, a selection of 

links in the email, or any link in the email.

8. Proceed with the regular sending method. Follow the instructions outlined in Chapter 6: 
Sending email:

○ Give your browser permission to load mixed content.
○ Select the email you want to send.
○ Select a Sender Property.
○ Decide whether or not you want to store email statistics for your subscribers.
○ Type your initials to certify you have the right to send email to your subscribers.
○ Decide whether to send this email immediately or to schedule it for later.

Click the Send to Campaign Members button.
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○

11
Running a report
iContact for Salesforce comes preloaded with nearly two dozen reports and 
dashboards to help you make sense of your data, track your ROI, and drive 
your business forward.

Running a report

1. Update statistics. For more information about updating statistics, see Chapter 9: 
Updating statistics.

2. Click the Reports tab.
3. Select an iContact folder from the list of folders on the left and select a report or 

dashboard within the folder.

iContact reports and dashboards
Running a report or viewing a dashboard is as easy as clicking the report or dashboard you 
need. This section outlines the reports and dashboards in detail so you can decide which 
starting point is best for you.

iContact Across Campaigns Dashboard folder
● Across iContact Campaigns. A high-level view of the success rate of your email 

marketing efforts across all iContact Campaigns.

iContact Campaign Contacts / Leads folder
This folder contains the most frequently-used reports. The reports show data for individual 
Contacts and Leads.

● iContact Campaign Contacts and Leads. The most functional report, iContact 
Campaign Contacts and Leads shows you a breakdown of all bounced, clicked, opened, 
and unsubscribed data. Should you ever need to create a custom report type, this is the 
report to work from. For more information about custom report types, see Custom Report 
Types.
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● iContact Campaign Contacts / Leads Bounced. This report shows the Contacts and 
Leads who hard bounced an email. For more information about bounces, see
Bounces  in the iContact Help Portal.

● iContact Campaign Contacts / Leads Clicked. This report shows the Contacts and 
Leads who clicked an email.

● iContact Campaign Contacts / Leads Opened. This report shows the Contacts and 
Leads who opened an email.

● iContact Campaign Contacts / Leads Unsubscribed. This report shows the Contacts 
and Leads who unsubscribed from an email.

iContact Campaign Dashboard folder
By default, the following reports will show you data for this current month, but you can 
customize the time frame to see the data you need for any time.

● Click Rate - Messages This Month. This report shows the click rate for all Campaigns 
and presents them in a graph for easy comparison.

● Open Rate - Messages This Month. This report shows the open rate for all Campaigns 
and presents them in a graph for easy comparison.

● Open Rate Per Campaign Created This Month. This report shows the open rate for all 
Campaigns created this month and presents them in a graph for easy comparison.

● Sends Per Month Per Campaign. This report shows the number of emails you sent for 
all Campaigns and presents them in a graph for easy comparison.

● Unsubscribe Rate Per Campaign Created This Month. This report shows the 
unsubscribe rate for all Campaigns created this month and presents them in a graph for 
easy comparison.

● Unsubscribe Rate - Messages This Month. This report shows the unsubscribe rate for 
all Campaigns and presents them in a graph for easy comparison.

iContact Campaign Reports folder
These reports show data that spans all Campaigns or all emails within your Campaigns.

● Average Click Rate - iContact Campaigns. This report shows the average click rate 
across all iContact Campaigns and presents the data in a graph for easy comparison. 
Use this report to gauge your overall click rate success.

● Average Open Rate - Monthly Newsletter. This report shows the average open rate for 
a fictitious Campaign called “Monthly Newsletter.” After selecting this report, click the 
magnifying glass to select one of your Campaigns to report on.

● Average Unsubscribe Rate - Across Messages. This report shows the average 
unsubscribe rate across all emails and presents the data in a graph for easy 
comparison. Use this report to see which emails triggered more unsubscribes than 
others.

https://app.icontact.com/icp/core/help/docs/view/en-us/icontact-for-salesforce/see-bounce-codes-in-icontact
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● Bounce Rate - All Messages. This report shows the bounce rate across all emails and 
presents the data in a graph for easy comparison. You want to keep your bounces to a 
minimum. Use this report to help identify emails and patterns that may have contributed 
to higher bounce rates.

● Click Rate - All Messages. This report shows the click rate across all emails and 
presents the data in a graph for easy comparison. You want to drive clicks and 
engagement as much as possible. Use this report to help identify emails and patterns 
that may have contributed to greater click rates.

● Complaint Rate - All Messages. This report shows the complaint rate across all emails 
and presents the data in a graph for easy comparison. Complaints are registered when 
Contacts or Leads mark your email as spam. Complaints are very damaging to your 
sending reputation and to ours, so you want to keep them to a minimum. Use this report 
to help identify emails and patterns that may have contributed to higher complaint rates.

● Open Rate - All Messages. This report shows the open rate across all emails and 
presents the data in a graph for easy comparison. You want to drive opens and 
engagement as much as possible. Use this report to help identify emails and patterns 
that may have contributed to greater open rates.

● Return on iContact Sent Messages. This report shows the return on iContact Sent 
Messages across all Campaigns and presents the data in a graph for easy comparison. 
If you associated Opportunities with iContact Campaigns, this report would sum the 
value of the Opportunities you won.

● Unsubscribe Rate - All Messages. This report shows the unsubscribe rate across all 
emails and presents the data in a graph for easy comparison. Unsubscribes are 
registered when Contacts or Leads opt out from receiving your email. Use this report to 
help identify emails and patterns that may have contributed to higher unsubscribe rates.

Customizing reports
All iContact reports and dashboards can be customized from their default presentation to 
display exactly the data you need. 

1. Click the Reports tab.
2. Select an iContact folder from the list of folders on the left and select a report within the 

folder.
3. For basic customizations, like summarizing information or changing the time frame of the 

report, use the options on the Report Results page. For advanced customizations, like 
adjusting filters, parameters, reporting columns, and column summaries, click the 
Customize button to access the Salesforce Report Builder. For more information about 
the Salesforce Report Builder, see Customizing Reports  in the Salesforce Success 
Community.

https://help.salesforce.com/HTViewHelpDoc?id=reports_builder_what_is.htm&language=en_US
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Custom report types
You may need to build a specific report that combines iContact Message Statistics data with 
other standard Salesforce fields. Because our reports, fields, and data are custom additions to 
your org, you must start by making a custom report type.

Clone the iContact report

1. Click Setup > Create (under Build) > Report Types. Click the Continue button if 
necessary.

2. Click iContact Contact and Lead Message Statistics.
3. Click the Clone button.
4. Give the report a new Report Type Label and Report Type Name, then click Save.

Make the Salesforce fields you need available to the cloned report

1. In the Fields Available For Reports section, click the Edit Layout button.
2. Locate the purple View section on the right side of the screen. Select iContact Message 

Statistics Fields (via lookup) from the dropdown.
3. Click Add fields related via lookup ».
4. Click the object link that contains the fields you need to add to the report. For example, 

click Campaign ».
5. Check the box next to each field you need to add to the report.
6. Click Ok.
7. Repeat Steps 3-6 as necessary for the other object links.
8. Click Save.

Create, customize, and run your report

1. Click the Reports Tab > New Report button.
2. Type the name of the report you created in the Quick Find box, select it, then click the 

Create button.
3. If necessary, you can customize the report further by dragging additional fields you may 

need from the Fields section on the left side of the screen and dropping them into the 
Preview section on the right.

4. Click Save, give the report a name, then click Save And Run Report.

For more information about reports and dashboards, including getting started resources, step-
by-step tutorials, and advanced documentation, see Reports and Dashboards  in the 
Salesforce Success Community.

https://help.salesforce.com/HTViewQuickStarts?id=000113375
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A
About your bundled iContact account
Your bundled iContact account is the engine that drives iContact for 
Salesforce. It’s where you build your emails, it’s the platform that sends 
them, and it’s where email statistics are collected in real time.

Your bundled iContact account is an iContact account that was uniquely configured to connect 
to Salesforce. When you log in, it will look exactly like a standard iContact account; however, 
many of the features and benefits covered in this chapter are not integrated into iContact for 
Salesforce. Those differences will be noted.

Features that aren’t integrated into iContact for Salesforce are still functional within your 
bundled iContact account -- you may use them if you choose to. They just will not be available 
in your Salesforce org.

If there are non-integrated features you’d like to use with Salesforce, we strongly encourage you 
to search the Salesforce AppExchange  for a solution as opposed to using iContact. 
Remember, the best solutions are integrated into your org.

Accessing your bundled iContact account
Access your bundled iContact account by clicking the iContact MessageBuilder tab or by 
logging in to iContact  directly.

Home
The iContact Home Page is a collection of widgets that gives you a bird’s eye view of the overall 
status of your account, your sends, and the latest updates from the iContact blog .

Most Recent Email widget
This widget displays statistics for the last email you sent, including the email subject; the 
number of subscribers the email was released to; the open and click rates; bounce, 

https://appexchange.salesforce.com/
https://www.icontact.com/login
https://www.icontact.com/blog
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unsubscribe, and complaint totals; the date and time of the send; and the date and time the 
send was completed. 

Contact Lists widget
Every time you send an email using iContact for Salesforce, a new list in created in your 
bundled iContact account and you’ll find a running tally of those lists here. iContact for 
Salesforce lists are designated by a special naming structure. Every list name starts with the 
prefix “SFDC Send” and contains the date and time of the send.

Social widget
Your bundled iContact account allows you to post directly to Facebook, Twitter, and LinkedIn. 
For more information about iContact’s social media integration features, see Enable a social 
media integration  and Post a message to a social media page  in the iContact Help Portal.

Latest iContact News widget
Stay up-to-date with the latest posts from the iContact Blog . Updated regularly, the iContact 
blog is an excellent resource for marketing insights, iContact tips and tricks, and customer 
success stories.

Account Health widget
The Account Health widget helps you gauge the number of emails you sent in the current 
month, the amount of space you’re using in your iContact Image Library, your subscriber count, 
and also has an Upgrade Your Account button.

The table below provides more information about the components of the Account Health widget.

Section Description

Messages Sent The number of emails you send will be shown as a fraction 
of your monthly send limit. Your count resets to 0 every 
month on the first of the month. Unused sends do not roll 
over to the next month. Should you ever exceed your 
monthly send limit, overage charges will be billed 
automatically to the default card on file and your emails will 
be released without interruption. If your account is invoiced, 
overages will temporarily disable sending until the invoice is 
paid.

Image Library Your bundled iContact account comes with 5MB of image 
hosting space. If you run out of space, you may delete old 
images from your library, contact iContact for Salesforce 

https://app.icontact.com/icp/core/help/docs/guid/en-us/dceffa63-d033-cacf-c4dd-e6423235eb0c
https://app.icontact.com/icp/core/help/docs/guid/en-us/dceffa63-d033-cacf-c4dd-e6423235eb0c
https://app.icontact.com/icp/core/help/docs/guid/en-us/841375c6-b8b0-8cd5-b592-98ac74789748
https://www.icontact.com/blog
mailto:salesforce@icontact.com?subject=Increase%2520Image%2520Library%2520Space&body=I%2520would%2520like%2520to%2520increase%2520my%2520Image%2520Library%2520space%252E%2520Is%2520that%2520something%2520you%2520can%2520help%2520me%2520with%253F
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Support and request more space (up to 25MB), or host 
images on a third-party site or on your website. For more 
information about images, see Image Library.

Subscriber Count The Subscriber Count is a running tally of the number of 
subscribers across all lists in your account. Because a new 
list is created every time you send an email using iContact 
for Salesforce, this number will grow quickly and it will 
eventually exceed your limit. This is normal and expected 
behavior. Because of this, the Subscriber Count has 
absolutely no bearing on your Account Health whatsoever.

Upgrade Your Account The Upgrade Your Account button is designed for 
standalone iContact customers. It can’t be used to upgrade 
your account. If you’re interested in upgrading your account, 
contact your Sales Representative.

Get Started With iContact widget
This widget is a great resource to help you get started with your bundled iContact account. It 
includes links to standalone iContact video tutorials  and a short Getting Started with iContact 
user guide . It also has a link to contact the iContact Support team.

Contacts
iContact doesn’t make a distinction between Contacts and Leads. We simply refer to everyone 
as a Contact. But what’s in a name? That which we call a rose by any other name would smell 
as sweet.

mailto:salesforce@icontact.com?subject=Increase%2520Image%2520Library%2520Space&body=I%2520would%2520like%2520to%2520increase%2520my%2520Image%2520Library%2520space%252E%2520Is%2520that%2520something%2520you%2520can%2520help%2520me%2520with%253F
mailto:sales@icontact.com?subject=Please%2520upgrade%2520my%2520account&body=I%2520would%2520like%2520to%2520upgrade%2520my%2520account%252E%2520Is%2520that%2520something%2520you%2520can%2520help%2520me%2520with%253F
https://www.icontact.com/resources/tutorials
https://www.icontact.com/content/resources/pdf/iContactGettingStarted.pdf
https://www.icontact.com/content/resources/pdf/iContactGettingStarted.pdf
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Lists
The Lists page is where you can find a collection of every list associated with your account. 
Remember, a new list is created every time you send an email from Salesforce, so this page will 
grow and grow.

1. Click the iContact MessageBuilder tab.
2. Click Contacts > Lists.

The table below provides more information about the columns on the Lists page.

Column Description

List Name The name of the list. All lists created from Salesforce 
Campaigns share the same naming structure, the “SFDC 
Send” prefix and the date and time of the send. You can give 
the lists you create in iContact any name you want.

Welcome Message Welcome Messages are automated emails that are sent to 
subscribers when they join a list. iContact Welcome 
Messages are not integrated into iContact for Salesforce.

Contacts Subscribed This column displays the number of subscribers on the 
corresponding list. Lists without subscribers will display a 
link to add subscribers. While it’s possible to add subscribers 
to a list in your bundled iContact account, we strongly 
discourage it. Subscribers added to a list in iContact aren’t 
associated with that list or its Campaign in Salesforce.

Visible You may choose to hide or display lists created in iContact 
on your subscribers’ Manage Your Subscription page. This 
column displays the visibility setting of the corresponding list. 
Because iContact for Salesforce lists are semantically 
named and you will eventually accumulate a lot of them, we 
hide them from your subscribers by default.

Manage List The Manage List button groups various administrative 
actions for lists. Click the button to access the options in a 
drop down menu.

Edit List. Edit the name of the list, add a description for the 
list, decide whether or not you’d like notifications for when 
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subscribers are added to or removed from the list, or update 
the list’s visibility on the Manage your Subscription page. As 
an iContact for Salesforce customer who builds and 
manages lists in Salesforce, you won’t get much value out of 
this feature.

Add Subscribers. Standalone iContact accounts can click 
this option to add subscribes to a list. As an iContact for 
Salesforce customer who builds and manages lists in 
Salesforce, you won’t get much value out of this feature. For 
more information about adding Campaign Members to a 
Campaign, see Chapter 5: Adding Campaign Members.

View Subscribers. See a detailed breakdown of the 
subscribers associated with the list and their subscription 
status.

View List Health. See a graphical breakdown of the 
subscribers associated with the list, their subscription status, 
and the evolution of the list over recent months. Because a 
new list is created every time you send an email from 
Salesforce, you won’t get much value out of this feature.

Delete List. Delete a list from iContact. Deleting a list in 
iContact will not affect Salesforce Campaigns, so you won’t 
get much value out of this feature.

Add Contacts
The Add Contacts page allows standalone iContact accounts to add subscribers to lists by 
uploading them from a file, by adding them one-by-one, or by copying and pasting them into 
their account. Because you have an iContact for Salesforce account and you manage your 
subscribers in Salesforce, you won’t get much value out of this page.

1. Click the iContact MessageBuilder tab.
2. Click Contacts > Add Contacts.

For more information about adding Campaign Members to a Campaign, see Chapter 5: Adding 
Campaign Members.
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Browse Contacts
The Browse Contacts page is the easiest way to see detailed information about your lists and 
the subscribers associated with them.

Access the Browse Contacts page:

1. Click the iContact MessageBuilder tab.
2. Click Contacts > Browse Contacts.

Every list in your account is accessible from the Limit To List Or Segment drop down. Select a 
list to see more information about the subscribers on that list including their subscription status.

The table below provides more information about the subscription status links on the Browse 
Contacts page.

Link Description

### Contacts in your account / 
associated with this list

When no list is selected, this is the total number of contacts 
in your account. When a specific list is selected, this is the 
total number of contacts on that list.

### Subscribed to lists / 
Subscribed

When no list is selected, this is the total number of unique 
contacts who are subscribed to lists. When a specific list is 
selected, this is the total number of contacts who are 
subscribed to that list.

### Bounced When no list is selected, this is the total number of contacts 
who have registered a hard bounce. When a specific list is 
selected, this is the total number of contacts who were once 
subscribed to that list but have since registered a hard 
bounce. For more information about bounces, see
Bounces  in the iContact Help Portal.

### Do Not Contact When no list is selected, this is the total number of contacts 
who have unsubscribed from your emails. When a specific 
list is selected, this is the total number of contacts who were 
once subscribed to that list but have since unsubscribed.

The Contacts Table is beneath the subscription status information. This table lists your contacts’ 
email address, name, and the date they were added to your account. The Manage Contact 
button in the right column of the table links to a contact’s iContact Contact Profile page and 
iContact Contact History page.

https://app.icontact.com/icp/core/help/docs/view/en-us/icontact-for-salesforce/see-bounce-codes-in-icontact
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The Actions Table is beneath the Contacts Table. The Actions Table allows you to copy 
contacts from one list to another, to unsubscribe contacts from a specific list, to delete contacts 
from your iContact account, to export contacts from your iContact account, or to move contacts 
into the Do Not Contact status.

Because you have an iContact for Salesforce account, you manage your contacts in Salesforce, 
so you won’t get much value out of copying or moving contacts in iContact. 

The Unsubscribe action will unsubscribe a contact from a list and the Do Not Contact action will 
move a contact into the Do Not Contact status.

Search Contacts
Your bundled iContact account makes it easy to search for contacts using a variety of criteria, 
including email address (full or partial addresses, like salesforce@icontact.com or simply 
icontact.com), name, business or address information, or even custom field data.

Access the Search Contacts page:

1. Click the iContact MessageBuilder tab.
2. Click Contacts > Search Contacts.

Segments
Segments were designed to give standalone iContact customers a way to drill down to specific 
contacts within a list so they could send them more targeted emails. Segments are not 
integrated into iContact for Salesforce.

Access the Segments page:

1. Click the iContact MessageBuilder tab.
2. Click Contacts > Segments.

The Targeted Send feature was built for iContact for Salesforce to give you the same 
functionality as Segments. If you’d like to target specific contacts with more relevant follow-up 
messaging, use the Targeted Send feature in Salesforce, not the Segment feature in iContact. 
For more information about targeted sends, see Chapter 10: Sending a Targeted Send.
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Sign-up Forms
Sign-up Forms allow standalone iContact customers to create a sign-up form for their website 
that funnels new contacts directly into their iContact account. Sign-up Forms are not integrated 
into iContact for Salesforce.

Access the Sign-up Forms page:

1. Click the iContact MessageBuilder tab.
2. Click Contacts > Sign-up Forms.

The Web-To-Lead form is a Salesforce tool that gives you the same functionality as Sign-up 
Forms. If you’d like to build a sign-up form for your website, use the Web-To-Lead feature in 
Salesforce, not the Sign-up Form feature in iContact.

Build a Web-To-Lead form

1. Click Setup > Customize (under Build) > Leads > Web-To-Lead.
2. Click the Edit button.
3. Check the Web-To-Lead Enabled box to enable your org to receive online leads, select 

your Default Response Template by clicking the magnifying glass icon in that section 
and choosing the Welcome Email you built in iContact, then click Save.

4. Click the Create Web-To-Lead Form button.
5. Build your form by adding or removing fields from the Available Fields and Selected 

Fields sections.

Note: At a minimum, you must include the Email field for iContact for Salesforce and the Last 
Name and Company fields for Salesforce. You may reorder fields by moving them up or 
down in the Selected Fields list.

6. Paste the URL for your Thank You page in the Return URL box, then click Generate.
7. Copy your form’s HTML and partner with your webmaster to paste it on your website, 

then click Finished.

Email
The most-frequently visited tab by iContact for Salesforce customers, the Email tab is where 
you build new emails, where you manage images stored in iContact, and where you can monitor 
the progress of an email or cancel an email in a pinch.
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Messages
The Messages page loads by default when you click the iContact MessageBuilder tab. Here 
you’ll find the iContact MessageBuilder and MessageCoder editors.

Access the Messages page:

1. Click the iContact MessageBuilder tab.

The Messages page has two primary sections: The Editor section at the top and the Draft 
section (called My Messages) at the bottom.

The Editor section
You’ll find the iContact MessageBuilder and MessageCoder editors in the Editor section. For 
more information about building emails in iContact, see Chapter 2: Creating an email.

The Draft section
The Draft section works overtime for iContact for Salesforce customers. In addition to housing 
all draft emails you save, the Draft section also retains a copy of every email sent from 
Salesforce. These copies are saved largely for your convenience. They can be copied, edited, 
or deleted as you see fit.

Pending Messages
The Pending Messages page is where you’ll find a list of all emails that are queued up on your 
outgoing mail server.

Access the Pending Messages page:

1. Click the iContact MessageBuilder tab.
2. Click Email > Pending Messages.

Emails that are sent with an immediate release time appear on this page as soon as your 
Campaign Member list uploads from Salesforce. Emails that are scheduled for a future date and 
time appear on this page roughly 2 hours before the scheduled release time.

If you ever need to cancel an email and you’re unable to cancel it in Salesforce by clicking the 
Cancel Send button, you may be able to cancel it on the Pending Messages page in iContact. 
For more information about canceling email, see Chapter 8: Canceling email.
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Surveys
Surveys allow standalone iContact customers to poll their contacts with public or private 
questionnaires. Surveys are not integrated into iContact for Salesforce.

Access the Surveys page:

1. Click the iContact MessageBuilder tab.
2. Click Email > Surveys.

If you’re interested in adding survey functionality to your Salesforce org, we recommend 
searching the AppExchange for a solution .

Autoresponders
Autoresponders allow standalone iContact customers to schedule and automate a series of 
emails at specified intervals. Autoresponders are not integrated into iContact for Salesforce.

Access the Autoresponders page:

1. Click the iContact MessageBuilder tab.
2. Click Email > Autoresponders.

The Scheduled Send feature was built for iContact for Salesforce to give you functionality that’s 
similar to autoresponders. If you’d like to send Campaign Members a series of emails at 
specified intervals, use the Scheduled Send feature in Salesforce, not the Autoresponder 
feature in iContact. For more information about scheduled sends, see Chapter 7: Scheduling 
email.

Image Library
Your bundled iContact account comes with a 5MB image library (upgradeable to a maximum of 
25MB) for images you want to include in your emails. 

Access the Image Library page:

1. Click the iContact MessageBuilder tab.
2. Click Email > Image Library.

In an effort to help you optimize your images for a swift delivery and small footprint in the inbox, 
images uploaded to the image library may not exceed 200KB in size.

https://appexchange.salesforce.com/category/surveys
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Should you ever need to include an image with a larger file size, we suggest hosting the file in 
Salesforce , hosting the file on your website, or hosting the file on a third-party hosting service 
and using the image’s public URL in MessageBuilder or MessageCoder.

Add an image to an email using its public URL

1. Copy the image’s public URL.
2. In MessageBuilder or MessageCoder, place your cursor where you want the image to 

go, then click the Image tab on the editor toolbar.
3. Click the Insert Image button in the Insert section.
4. Click From Web, paste the image’s public URL in the search box, then click Find.
5. Click the blue check.

Social
Your bundled iContact account can be connected to your Facebook, Twitter, and LinkedIn 
accounts to help you create, schedule, share, and track your posts and tweets.

The Social tab was not integrated into iContact for Salesforce. In order to use this feature, you 
must manage lists and subscribers in iContact and you must send email directly from iContact. 
As an iContact for Salesforce customer, you manage lists and subscribers in Salesforce and 
you send email from Salesforce.

Reports
While you should always update statistics in Salesforce to get the most out of the iContact for 
Salesforce integration, your stats are always available in your bundled iContact account. For 
more information about seeing email statistics in Salesforce, see Chapter 9: Updating statistics.

Last Message
This is a shortcut to the Track My Email Message page for the last email you sent.

Access the Track My Email Message page for the last email you sent:

1. Click the iContact MessageBuilder tab.
2. Click Reports > Last Message.

The Track My Email Message page has six primary sections: Email Information, Email Impact, 
Device Usage, Social Engagement, Lists And Segments, and Details.

https://help.salesforce.com/apex/HTViewHelpDoc?id=docs_upload.htm
https://help.salesforce.com/apex/HTViewHelpDoc?id=docs_upload.htm
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Email Information
The Email Information section displays the subject of your email, the date and time of the send, 
the time it took to complete the send, and the number of Campaign Members the email was 
sent to.

The number of Campaign Members the email was sent to is usually lower than the number of 
Campaign Members associated with the Campaign in Salesforce. This is normal. For more 
information about why there is a difference between these numbers, see Why doesn’t iContact 
send email to all Campaign Members?

Email Impact
The Email Impact section shows the percentage of subscribers who opened, clicked, or 
bounced your email, as well as the subscribers who couldn’t be tracked. It also shows the 
number of subscribers who unsubscribed from your account and the number who registered a 
complaint about receiving your email.

The table below provides more information about the engagement level of your subscribers and 
how it’s measured by iContact.

Engagement Level Description

Opened The number of subscribers who opened your email.

iContact can track HTML emails built using MessageBuilder 
or MessageCoder. Text-only emails can not be tracked.

iContact tracks opens using a Web Bug, a 1x1 embedded 
pixel that’s activated when images are downloaded for your 
email. iContact can also track opens when links are clicked 
in the email.

Bounced The number of subscribers who bounced your email.

Bounced emails represent unreachable subscribers whose 
incoming mail server rejected, or bounced, your email. There 
are a variety of reasons why a subscriber may be 
unreachable. For example, their server may be down for 
maintenance, their inbox may no longer exist, or strict anti-
spam rules may reject your email based on its content.

iContact tracks two kinds of bounces, soft bounces, which 
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are temporary, and hard bounces, which are permanent. For 
more information about bounces, see Bounces  in the 
iContact Help Portal.

No Info The number of untrackable subscribers.

This category includes subscribers who didn’t open your 
email as well as those who opened it in an untrackable way. 
For example, they opened the email but didn’t download 
images (and our tracking pixel), they didn’t click a link, or 
their server was muted by an administrator to prevent it from 
alerting us of the open. For more information about 
subscribers designated as No Info, see Why is there “No 
Info” for so many people?

Clicked The number of subscribers who clicked a link in your email.

iContact link tracking code is automatically added to each 
link when email is sent, provided that this setting wasn’t 
turned off on the Sender Property associated with this send. 
For more information about Sender Properties, see Sender 
Properties.

Unsubscribed The number of subscribers who unsubscribed from your 
account.

Complained The number of subscribers who marked your email as spam. 

Subscribers who mark an email as spam are automatically 
unsubscribed from your account.

Device Usage
The Device Usage section shows you which devices your contacts used when they opened your 
email: Smartphone, Tablet, or Computer.

Social Engagement
Standalone iContact customers can post directly to social media when they send email. That 
feature was not integrated into iContact for Salesforce, so this section will always be empty.

https://app.icontact.com/icp/core/help/docs/view/en-us/icontact-for-salesforce/see-bounce-codes-in-icontact
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Lists And Segments
This section displays the name of the list your email was sent to. iContact for Salesforce lists 
are designated by a special naming structure. Every list name starts with the prefix “SFDC 
Send” and contains the date and time of the send.

Details
The Details section is accessible after clicking the View Details button. The Details section 
contains an itemized list of subscribers in the click, open, no info, unsubscribe, and bounce 
statuses. 

Sent Messages
The Sent Messages page contains a permanent record of every email that was sent from your 
account, the Sender Property associated with the emails, the date the emails were sent, and the 
number of subscribers who received them.

Access the Sent Messages page:

1. Click the iContact MessageBuilder tab.
2. Click Reports > Sent Messages.

Surveys
The Surveys page under the Reports tab allows standalone iContact customers to track the 
results of their surveys.

Access the Surveys page under the Reports tab:

1. Click the iContact MessageBuilder tab.
2. Click Reports > Surveys.

Surveys are not integrated into iContact for Salesforce. If you’re interested in adding survey 
functionality to your Salesforce org, we recommend searching the AppExchange for a
solution .

https://appexchange.salesforce.com/category/surveys
https://appexchange.salesforce.com/category/surveys
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Autoresponders
The Autoresponders page under the Reports tab allows standalone iContact customers to track 
the email statistics for their autoresponders.

Access the Autoresponders page under the Reports tab:

1. Click the iContact MessageBuilder tab.
2. Click Reports > Autoresponders.

Autoresponders are not integrated into iContact for Salesforce. If you’d like to send Campaign 
Members a series of emails at specified intervals, use the Scheduled Send feature in 
Salesforce. For more information about scheduled sends, see Chapter 7: Scheduling email.

Tracking Dashboard
The Tracking Dashboard allows standalone iContact customers to review their email statistics 
with more detailed charts and graphs. 

Access the Tracking Dashboard:

1. Click the iContact MessageBuilder tab.
2. Click Reports > Tracking Dashboard.

iContact for Salesforce customers can always review their email statistics on the iContact 
Tracking Dashboard, but to get the most out of iContact for Salesforce, it’s best to update 
statistics in Salesforce and to review them there. For more information about seeing email 
statistics in Salesforce, see Chapter 9: Updating statistics.

Account Settings
The administrative settings for your bundled iContact account are organized in the account drop 
down in the upper right corner of iContact. The account drop down usually shows the name of 
the iContact Account Administrator, but it may display someone else’s name. The iContact 
Account Administrator is the only individual who may authorize account upgrades, downgrades, 
and cancellations. This individual receives password reset links and other administrative emails 
from iContact.
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User Settings
The User Settings page displays your username and usually displays the name of the Account 
Administrator, but it may display someone else’s name.

Access the User Settings page:

1. Click the iContact MessageBuilder tab.
2. Click Account drop down > User Settings. The Account drop down displays your 

name or a colleague’s name. 

You may also update your iContact account password on this page.

Warning: Never update the iContact account password without also updating the iContact 
API password that links your iContact account to your Salesforce account. For information 
about updating your iContact account and iContact API password, see iContact login page.

Contact Information
This page contains the contact information of the iContact Account Administrator and will always 
display his or her name. The information on this page can not be changed without the iContact 
account password.

Access the Contact Information page:

1. Click the iContact MessageBuilder tab.
2. Click Account drop down > Contact Information. The Account drop down displays 

your name or a colleague’s name. 

Billing Information
This page contains the billing information for your account. 

Access the Billing Information page:

1. Click the iContact MessageBuilder tab.
2. Click Account drop down > Billing Information. The Account drop down displays your 

name or a colleague’s name. 
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Invoices And Receipts
This page contains a list of every invoice and receipt that is generated for your account.

Access the Invoices And Receipts page:

1. Click the iContact MessageBuilder tab.
2. Click Account drop down > Invoices And Receipts. The Account drop down displays 

your name or a colleague’s name. 

Social Media Settings
This page is where you enable or disable your Facebook, Twitter, and LinkedIn accounts, as 
well as your Social Media Sharebar.

1. Click the iContact MessageBuilder tab.
2. Click Account drop down > Social Media Settings. The Account drop down displays 

your name or a colleague’s name. 

Sender Properties
This page contains a permanent record of every Sender Property that is created for your 
account. We use Sender Properties to help you remain compliant with our anti-spam policy .

Access the Sender Properties page:

1. Click the iContact MessageBuilder tab.
2. Click Account drop down > Sender Properties. The Account drop down displays your 

name or a colleague’s name. 

For more information about Sender Properties, see Sender Properties.

https://www.icontact.com/legal/anti-spam-policy
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Custom Fields
This page stores a list of all custom fields and merge fields that have been used to merge data 
into an email.

Access the Custom Fields page:

1. Click the iContact MessageBuilder tab.
2. Click Account drop down > Custom Fields. The Account drop down displays your 

name or a colleague’s name. 

For more information about merge fields, see Merge fields.

Upgrade
This page allows standalone iContact customers to upgrade their accounts, but it can not be 
used to upgrade your account.

When you’re ready to upgrade, please reach out to our Sales team.

iContact Sales can be reached at 1 (877) 820-7837, internationally at +1 (919) 957-6150, or by 
email at sales@icontact.com.

iContact Sales hours are Monday - Friday, 9 a.m. - 6 p.m. EST.

mailto:sales@icontact.com?subject=Upgrade%2520my%2520account&body=I%2520would%2520like%2520to%2520upgrade%2520my%2520account%252E%2520Is%2520this%2520something%2520you%2520can%2520help%2520me%2520with%253F
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B
Frequently-asked questions
You’ve got questions. We’ve got answers.

Can I embed video in my email?
No. iContact for Salesforce was optimized for maximum compatibility across a wide range of 
inboxes and many popular inboxes still don’t support embedded video in emails, so neither does 
iContact for Salesforce. Instead, we recommend hosting the video somewhere online and 
linking to it using its thumbnail image.

Can I send attachments?
No. Even though it’s possible to attach a file to a template in Salesforce, iContact for Salesforce 
will not send the file with your email. Incoming mail filters tend to strip away attachments from 
bulk emails and flag the emails as spam. The best alternative is to host the file on your website 
and to link to it in your email.

How frequently should I update statistics?
Generally speaking, email has a 3-7 day lifecycle. That, of course, is influenced by your industry 
and the engagement level of your subscribers.

If your industry never sleeps and your subscribers are very engaged with your content, we 
recommend updating statistics after the first hour, after the first day, and after the third day. On 
the other hand, if your industry and subscribers move at a slower pace, we recommend 
updating statistics after the first day, after the third day, and after the seventh day.

Some of my subscribers opened and clicked a lot. Is the tracking broken?
No. When you see an unreasonably high number of opens or clicks, it’s usually an indicator that 
the subscriber forwarded the email to his or her network or of anti-virus software that’s vetting 
your email before your subscriber gets to it.

It’s not possible for us to know who your subscribers may forward an email to, so all subsequent 
opens and clicks will be logged under the original recipient’s email address.
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In the seconds it takes an email or webpage to load after we click it, anti-virus software can 
review our actions dozens of times in the background to make sure everything is safe. If it’s 
opening the email or clicking links, those opens and clicks are recorded by our system.

Because forwarded emails and anti-virus software artificially inflate your open and click totals, 
we include Unique Opens and Unique Clicks as a part of your email statistics.

Why doesn’t iContact send email to all Campaign Members?
iContact maintains a large database of email addresses and their deliverability status. The 
database is aggregated from the sends of every customer we serve. We run lists through this 
database and clean them up before we send email. We remove duplicated, bounced, 
unsubscribed, and otherwise undeliverable email addresses from your Campaign lists.

Below are some of the most common reasons why we remove addresses from your Campaign 
lists:

● Salesforce allows you to add Contacts or Leads to a Campaign whether they have an 
email address or not; iContact can not deliver an email without an email address.

● Salesforce allows you to add duplicate Contacts or Leads to a Campaign; iContact will 
deliver 1 email to each email address – no duplicate email addresses are permitted.

● Salesforce allows you to add unique Contacts or Leads who share the same email 
address to a Campaign; again, iContact will deliver 1 email to each email address – no 
duplicate email addresses are permitted.

● Salesforce allows you to add Contacts or Leads to a Campaign even if they 
unsubscribed from your lists in the past; iContact will not deliver email to an 
unsubscribed address.

● Salesforce allows you to add Contacts or Leads to a Campaign with a bounced, invalid, 
or otherwise undeliverable email address; iContact will not deliver email to a bounced, 
invalid, or otherwise undeliverable email address.

● Salesforce allows you to add Contacts or Leads to a Campaign with a role email address 
(for example, admin@, marketing@, support@, etc.); iContact will not deliver email to 
role email addresses. Click here for a list of role email addresses iContact does not 
deliver to .

Keep in mind that when someone bounces or unsubscribes, they aren't automatically removed 
from your Campaigns because Salesforce doesn't know that you're using the Campaign for 
email marketing. As far as Salesforce is concerned, you could be using the Campaign for direct 
mail marketing, telemarketing, or anything else.

Given the way we prepare lists for delivery, it is perfectly normal for the number of Campaign 
Members and the number of delivered emails to differ.

https://app.icontact.com/icp/core/help/docs/view/en-us/icontact/deliverability-best-practices/unable-to-send-messages-to-role-email-addresses
https://app.icontact.com/icp/core/help/docs/view/en-us/icontact/deliverability-best-practices/unable-to-send-messages-to-role-email-addresses
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Before any send, we recommend updating statistics to be sure you have the most up-to-date 
Campaign Member information as possible. It is also a good idea to clean up your Campaigns 
and remove bounced or unsubscribed Campaign Members from time to time. But don't go 
overboard: email is a real time technology and it may prove difficult to reconcile those numbers 
perfectly.

For more information about updating statistics, see Chapter 9: Updating Statistics. For more 
information about removing bounced or unsubscribed email addresses, see Remove bounced 
or unsubscribed email addresses from a Campaign.

Why is there “No Info” for so many people?
Subscribers who don’t bounce an email or open an email will be recorded as “No Info” because 
there is no information for us to report on.

iContact tracks an open when a subscriber downloads our tracking pixel or clicks a link.

Many inboxes are configured to download and display images by default -- our tracking pixel is 
downloaded with those images -- but not every inbox is configured this way. It’s also possible for 
the subscriber or the subscriber’s admin to turn off images entirely and for an admin to mute a 
server from relaying back to us that an email was opened.

The best way to reduce the number of “No Info” subscribers is to write engaging content, to 
include images that enhance your content, and to encourage your subscribers to click your Call 
To Action link. 
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C
Tutorials
We want to empower you to unleash the full potential of iContact for 
Salesforce. Once you’ve mastered the fundamentals, try your hand at 
these tutorials.

iContact for Salesforce is a powerful and flexible email marketing solution that grows with you. 
In this chapter you’ll learn advanced reporting skills, how to manage Campaign Members like a 
pro, how to use dynamic merge fields, and so much more.
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Add additional fields to the iContact
related lists
Adding additional fields to the iContact related lists lets you see more information in the context 
of your email marketing stats. For example, adding a contact’s Account Name field lets you see 
at a glance how contacts at a specific company interact with your email.

This tutorial outlines the steps to add a contact’s Account Name field to the iContact Message 
Statistic related list. These steps can be followed to add myriad other fields to other lists too.

Make the field you want to add to the list available

1. Click Setup > Create (under Build) > Objects > iContact Message Statistic.
2. In the Fields & Relationships section, click the New button.
3. Select the Formula data type, then click Next.
4. Type Account Name in the Field Label box, select the Text formula return type, then 

click Next.
5. Click the Advanced Formula tab > Insert Field button. iContact Message Statistic 

should be highlighted in the window that pops up.
6. In the second column, click Contact >; in the third column, click Account >; in the fourth 

column, click Account Name, then scroll to the right and click the Insert button.
7. In the Blank Field Handling section at the bottom of the page, select Treat blank fields 

as blanks, then click Next.
8. If you’re using Enterprise Edition or Unlimited Edition, decide which profiles will see the 

field, then click Next. Professional Edition doesn’t support profiles, so if you’re using 
Professional, you can skip this step.

9. Confirm the iContact Message Statistic Layout is checked, then click Save.

Add the field to the list

1. Click Setup > Create (under Build) > Objects > iContact Sent Message.
2. Click the Page Layouts link at the top of the page and click Edit next to iContact Sent 

Message Layout.
3. Locate the iContact Message Statistic related list and click the wrench icon.
4. Select Account Name in the Available Fields section and add it to the Selected Fields 

section, then click Ok.
5. In the silver and gray box at the top of the page, click the Save button.
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Create an iContact for Salesforce 
Permission Set
Creating an iContact for Salesforce Permission Set lets you assign iContact for Salesforce 
permissions to other users on-the-fly without making changes to their profile.

Note: You may not use all of the following objects or fields but they’re all required for iContact 
for Salesforce to work.

Create the iContact for Salesforce Permission Set and assign the iContact for Salesforce 
app to it

1. Click Setup > Manage Users (under Administer) > Permission Sets.
2. Click the New button.
3. In the label field, type iContact for Salesforce, then click Save.
4. In the Apps section, click Assigned Apps, then click the Edit button.
5. Move the iContactforSF.iContact Email Marketing app from the Available Apps 

section on the left to the Enabled Apps section on the right, then click Save.

Add Campaign object permissions

1. Click the More button next to Assigned Apps and select Object Settings.
2. Click Campaigns, then click the Edit button.
3. In the Campaign: Record Type Assignments section, check iContact for Salesforce.
4. In the Object Permissions section, check Read, Create, and Edit, then click Save.

Add Contact and Lead object and field permissions

1. Click the More button next to Campaigns, select Contacts, then click the Edit button.
2. In the Object Permissions section, check Read, Create, and Edit.
3. In the Field Permissions section, check Read Access and Edit Access for the following 

fields, then click Save:

○ Email
○ Email Opt Out
○ Fax
○ iContact Contact ID
○ Mailing Address (for Contacts) / Address (for Leads)
○ Name
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○ Phone

4. Repeat from Step 1, this time selecting Leads.

Add the iContact Clicked Links, iContact Global Statistics, and iContact Message 
Statistics permissions

1. Click the More button next to Leads, select iContact Clicked Links, then click the Edit 
button.

2. In the Object Permissions section, check Read and Create, then click Save.
3. Repeat from Step 1 for the iContact Global Statistics and iContact Message 

Statistics objects.

Enable the iContact for Salesforce Visualforce pages

1. Click the More button next to Object Settings and select Visualforce Page Access, 
then click the Edit button.

2. Move every Visualforce page that starts with the prefix iContactforSF from the Available 
Visualforce Pages section on the left to the Enabled Visualforce Pages section on the 
right, then click Save.

Assign the iContact for Salesforce Permission Set and check the Marketing User box for 
the new iContact for Salesforce users

1. Click Setup > Manage Users (under Administer) > Users.
2. Locate the user you want to assign the permission set to and click his or her name.
3. Click the Edit Assignments button in the Permission Set Assignments section.
4. Move the iContact for Salesforce permission set from the Available Permission Sets 

section on the left to the Enabled Permission Sets section on the right, then click Save.
5. Click the Edit button, check the Marketing User box, then click Save.
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Delete iContact Message Statistics data
The primary benefit of iContact for Salesforce is the email statistics we bring into your org. If you 
don’t have an unlimited data storage plan with Salesforce, your statistics will eventually 
consume your available space. If you decide not to upgrade your data storage plan, then you 
can follow this tutorial to delete old data.

Warning: The iContact for Salesforce Support team has not been trained to remove data from 
your org or to troubleshoot any issues that may come up during the process.

Enterprise or Unlimited edition
If you’re using Salesforce Enterprise or Unlimited edition, you can use Data Loader to delete 
iContact Message Statistics data.

1. Click Setup > Data Management (under Administer) > Data Loader.
2. Target the data on the iContactforSF__iContact_Message_Statistic__c object.

Note: Please consult the Salesforce Data Loader User Guide  or partner with Salesforce 
Support if you need help with Data Loader. They can be reached at 1 (800) 667-6389, online 
at help.salesforce.com , or by email at supportresponse@salesforce.com.

Professional edition
If you’re using Salesforce Professional edition, please search the AppExchange  for a 
solution. Many customers have had success with dataloader.io  and Jitterbit .

Note: For help with third-party tools, please reach out to that company through their provided 
support channels.

Using iContact for Salesforce after you delete data
Deleting data may affect the aggregated stats that are displayed on the dashboards for 
Campaigns and individual emails, but there are no other downsides to deleting data.

To help keep your data under control moving forward, we recommend cleaning up statistics 
regularly, strategically updating statistics at the email level, using iContact for Salesforce Lite, or 
upgrading your data storage with Salesforce.

http://na16.salesforce.com/help/pdfs/en/salesforce_data_loader.pdf
https://help.salesforce.com/
mailto:supportresponse@salesforce.com
https://appexchange.salesforce.com/results?keywords=data%2520loader
https://appexchange.salesforce.com/listingDetail?listingId=a0N30000009w8ZBEAY
https://appexchange.salesforce.com/listingDetail?listingId=a0N300000016ZoVEAU
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Strategically updating statistics at the email level
Strategically updating statistics means clicking the Update Statistics button only on the specific 
emails you're interested in. By contrast, clicking the Update Statistics button for a Campaign will 
update statistics for every email sent to that Campaign, including the emails that may not be 
mission-critical.

Using iContact for Salesforce Lite
When using iContact for Salesforce Lite, we will not store stats for individual Contacts or Leads 
in Salesforce. You will not run out of data storage as quickly as before but you will lose the 
ability to see which individuals are opening and clicking, to run reports on individual Contacts or 
Leads, and to send Targeted Sends. What’s more, emails sent using iContact for Salesforce 
Lite can not retrieve individual stats later if iContact for Salesforce Lite is turned off.

Turn on iContact for Salesforce Lite

1. Click the + tab for all tabs.
2. Click iContact Configuration – the singular option with our logo.
3. Click the Edit button.
4. In the Configure section at the top of the page, check the Enable Lite Version box.
5. Click Save.

iContact for Salesforce Lite prevents iContact for Salesforce from storing individual stats in your 
org, but your bundled iContact account will continue to track and store that data. You can 
always log in to your bundled iContact account to see the data you’re missing in Salesforce.

See stats in your bundled iContact account

1. Click the iContact MessageBuilder tab or log in to iContact directly .
2. In iContact, click Reports > Sent Messages.

https://www.icontact.com/login
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Customizing the Campaign Page layout after deleting data
Finally, use caution when clicking the Update Statistics button on the Campaign page. If you 
update stats for a Campaign you already cleaned up, all the stats you deleted will be loaded 
back into Salesforce.

Remove the Update Statistics button from the Campaign page

1. Click Setup > Customize (under Build) > Campaigns > Page Layouts.
2. Click Edit on the left side of the iContact Campaign Layout.
3. In the purple and gray box, click Buttons.
4. Drag the Update Statistics button from the Campaign Detail section and drop it into the 

Buttons section in the purple and gray box, then click Save.
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Merge fields
Merge fields make it easy for you to dynamically customize an email for each individual in a 
Campaign. For example, you can greet your subscribers by name, sign an email with the name 
of a Contact’s or Lead’s Owner, or even remind someone of an outstanding balance due on 
their account and the amount of that balance.

Note: If you need help resolving an “Unable to validate merge fields” error, see Unable to 
validate merge fields.

Warning: Never send an email that contains merge fields without first confirming they work. 
Always test emails that contain merge fields by sending a test email to your iContact for 
Salesforce Test Campaign.

Supported iContact merge fields
iContact for Salesforce supports all iContact merge fields that have an equivalent Salesforce 
field. The table below outlines the supported iContact merge fields.

iContact field Salesforce Contact field Salesforce Lead field

[address1] {!Contact.MailingStreet} {!Lead.Street}

[address2] NOT SUPPORTED NOT SUPPORTED

[business] NOT SUPPORTED {!Lead.Company}

[city] {!Contact.MailingCity} {!Lead.City}

[email] {!Contact.Email} {!Lead.Email}

[fax] {!Contact.Fax} {!Lead.Fax}

[fname] {!Contact.FirstName} {!Lead.FirstName}

[lname] {!Contact.LastName} {!Lead.LastName}

[phone] {!Contact.Phone} {!Lead.Phone}

[prefix] {!Contact.Salutation} {!Lead.Salutation}
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[state] {!Contact.MailingState} {!Lead.State}

[suffix] NOT SUPPORTED NOT SUPPORTED

[zip] {!Contact.MailingPostalCode} {!Lead.PostalCode}

iContact for Salesforce supports standard and custom Salesforce fields that use specific 
standard Salesforce objects and specific field data types. The table below outlines the 
supported Salesforce objects and field data types.

Supported standard objects Supported field data types

Contact Auto Number

Lead Checkbox

Campaign Currency

Organization Email

Account Geolocation

User Number

Percent

Phone

Text

URL

Salesforce Contact merge fields
The following is a list of standard and default custom Contact merge fields. For more information 
about creating your own custom fields, see Create a custom field in Salesforce  in the 
iContact Help Portal.

Standard Contact merge fields
{!Contact.AssistantName}
{!Contact.AssistantPhone}
{!Contact.CreatedBy}
{!Contact.CreatedById}
{!Contact.Department}
{!Contact.Email}
{!Contact.Fax}

https://app.icontact.com/icp/core/help/docs/view/en-us/icontact-for-salesforce/create-a-custom-field-in-salesforce
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{!Contact.FirstName}
{!Contact.HomePhone}
{!Contact.LastModifiedBy}
{!Contact.LastModifiedById}
{!Contact.LastName}
{!Contact.LeadSource}
{!Contact.MailingCity}
{!Contact.MailingCountry}
{!Contact.MailingPostalCode}
{!Contact.MailingState}
{!Contact.MailingStreet}
{!Contact.MobilePhone}
{!Contact.Name}
{!Contact.OtherCity}
{!Contact.OtherCountry}
{!Contact.OtherPhone}
{!Contact.OtherPostalCode}
{!Contact.OtherState}
{!Contact.OtherStreet}
{!Contact.OwnerId}
{!Contact.OwnerFullName}
{!Contact.Owner}
{!Contact.OwnerEmail}
{!Contact.OwnerFirstName}
{!Contact.OwnerId}
{!Contact.OwnerLastName}
{!Contact.OwnerPhone}
{!Contact.OwnerTitle}
{!Contact.Phone}
{!Contact.Salutation}
{!Contact.Title}

Default custom Contact merge fields
{!Contact.iContact_Contact_Id__c}
{!Contact.Languages__c}
{!Contact.Level__c}
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Salesforce Lead merge fields
The following is a list of standard and default custom Lead merge fields.

Standard Lead merge fields
{!Lead.AnnualRevenue}
{!Lead.City}
{!Lead.Company}
{!Lead.Country}
{!Lead.CreatedBy}
{!Lead.CreatedById}
{!Lead.Email}
{!Lead.Fax}
{!Lead.FirstName}
{!Lead.Industry}
{!Lead.LastModifiedBy}
{!Lead.LastModifiedById}
{!Lead.LastName}
{!Lead.LeadSource}
{!Lead.Name}
{!Lead.NumberOfEmployees}
{!Lead.Owner}
{!Lead.OwnerEmail}
{!Lead.OwnerFirstName}
{!Lead.OwnerFullName}
{!Lead.OwnerId}
{!Lead.OwnerLastName}
{!Lead.OwnerPhone}
{!Lead.OwnerTitle}
{!Lead.Phone}
{!Lead.PostalCode}
{!Lead.Rating}
{!Lead.Salutation}
{!Lead.State}
{!Lead.Status}
{!Lead.Street}
{!Lead.Title}
{!Lead.Website}
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Default custom Lead merge fields
{!Lead.CurrentGenerators__c}
{!Lead.iContact_Contact_Id__c}
{!Lead.Lead_Help_System__c}
{!Lead.NumberofLocations__c}
{!Lead.Primary__c}
{!Lead.ProductInterest__c}
{!Lead.Secondary__c}
{!Lead.SICCode__c}

Salesforce Campaign merge fields
The following is a list of standard and default custom Campaign merge fields.

Standard Campaign merge fields
{!Campaign.ActualCost}
{!Campaign.AmountAllOpportunities}
{!Campaign.AmountWonOpportunities}
{!Campaign.BudgetedCost}
{!Campaign.CreatedBy}
{!Campaign.CreatedById}
{!Campaign.ExpectedRevenue}
{!Campaign.Id}
{!Campaign.IsActive}
{!Campaign.LastModifiedBy}
{!Campaign.LastModifiedById}
{!Campaign.Name}
{!Campaign.NumberOfContacts}
{!Campaign.NumberOfConvertedLeads}
{!Campaign.NumberOfLeads}
{!Campaign.NumberOfOpportunities}
{!Campaign.NumberOfResponses}
{!Campaign.NumberOfWonOpportunities}
{!Campaign.NumberSent}
{!Campaign.OwnerId}
{!Campaign.RecordTypeId}
{!Campaign.Status}
{!Campaign.Type}
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Default custom Campaign merge fields
{!Campaign.Average_Bounce_Rate__c}
{!Campaign.Average_Click_Rate__c}
{!Campaign.Average_Open_Rate__c}
{!Campaign.Average_Unsubscribe_Rate__c}
{!Campaign.Bounce_Rate_Warning_Threshold_1__c}
{!Campaign.Bounce_Rate_Warning_Threshold_2__c}
{!Campaign.Click_Rate_Success_Threshold_1__c}
{!Campaign.Click_Rate_Success_Threshold_2__c}
{!Campaign.Message_Statistic_Count__c}
{!Campaign.Open_Rate_Success_Threshold_1__c}
{!Campaign.Open_Rate_Success_Threshold_2__c}
{!Campaign.Total_Bounce_Rate__c}
{!Campaign.Total_Click_Rate__c}
{!Campaign.Total_Open_Rate__c}
{!Campaign.Total_Unsubscribe_Rate__c}
{!Campaign.Unsubscribe_Rate_Warning_Threshold_1__c}
{!Campaign.Unsubscribe_Rate_Warning_Threshold_2__c}

Salesforce Organization merge fields
The following is a list of standard Organization merge fields.

Standard Organization merge fields
{!Organization.ComplianceBccEmail}
{!Organization.Country}
{!Organization.DefaultCalendarAccess}
{!Organization.DefaultCampaignAccess}
{!Organization.DefaultCaseAccess}
{!Organization.DefaultContactAccess}
{!Organization.DefaultLeadAccess}
{!Organization.DefaultLocaleSidKey}
{!Organization.DefaultOpportunityAccess}
{!Organization.Division}
{!Organization.Fax}
{!Organization.FiscalYearStartMonth}
{!Organization.Id}
{!Organization.LanguageLocaleKey}
{!Organization.Name}
{!Organization.OrganizationType}
{!Organization.Phone}
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{!Organization.PostalCode}
{!Organization.PreferencesRequireOpportunityProducts}
{!Organization.PrimaryContact}
{!Organization.ReceivesAdminInfoEmails}
{!Organization.ReceivesInfoEmails}
{!Organization.Street}
{!Organization.UiSkin}
{!Organization.WebToCaseDefaultOrigin}

Salesforce Account merge fields
The following is a list of standard and default custom Account merge fields.

Standard Account merge fields
{!Account.AccountNumber}
{!Account.AnnualRevenue}
{!Account.BillingCity}
{!Account.BillingCountry}
{!Account.BillingPostalCode}
{!Account.BillingState}
{!Account.BillingStreet}
{!Account.CreatedBy}
{!Account.CreatedById}
{!Account.Fax}
{!Account.Id}
{!Account.Industry}
{!Account.LastModifiedBy}
{!Account.LastModifiedById}
{!Account.Name}
{!Account.NumberOfEmployees}
{!Account.Owner}
{!Account.OwnerEmail}
{!Account.OwnerFirstName}
{!Account.OwnerFullName}
{!Account.OwnerId}
{!Account.OwnerLastName}
{!Account.OwnerPhone}
{!Account.Ownership}
{!Account.OwnerTitle}
{!Account.Parent}
{!Account.ParentId}
{!Account.Phone}
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{!Account.Rating}
{!Account.ShippingCity}
{!Account.ShippingCountry}
{!Account.ShippingPostalCode}
{!Account.ShippingState}
{!Account.ShippingStreet}
{!Account.Sic}
{!Account.Site}
{!Account.TickerSymbol}
{!Account.Type}
{!Account.Website}

Default custom Account merge fields
{!Account.Active__c}
{!Account.CustomerPriority__c}
{!Account.NumberofLocations__c}
{!Account.SLA__c}
{!Account.SLASerialNumber__c}
{!Account.UpsellOpportunity__c}

Salesforce User merge fields
The following is a list of standard User merge fields.

Standard User merge fields
{!User.Alias}
{!User.City}
{!User.CommunityNickname}
{!User.CompanyName}
{!User.Contact}
{!User.ContactId}
{!User.Country}
{!User.Department}
{!User.Division}
{!User.Email}
{!User.EmployeeNumber}
{!User.Extension}
{!User.Fax}
{!User.FirstName}
{!User.Id}
{!User.IsActive}
{!User.LastName}
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{!User.Manager}
{!User.ManagerId}
{!User.MobilePhone}
{!User.Name}
{!User.Phone}
{!User.PostalCode}
{!User.Profile}
{!User.ProfileId}
{!User.State}
{!User.Street}
{!User.Title}
{!User.Username}

Before using merge fields
There are three important checks to make before using merge fields.

1. Determine if your Campaign contains only Contacts or Leads or if it contains both 
Contacts and Leads. If the Campaign contains only Contacts or Leads, use merge 
fields built with the Contact or Lead object, respectively. If the Campaign contains both 
Contacts and Leads and you’re merging a field that has an iContact merge field 
equivalent, then use the iContact merge field. If your Campaign contains both Contacts 
and Leads and you use both a Contact and Lead merge field, then you will merge the 
data twice. Using the iContact merge field ensures the data is merged just once.

Note: If you’re sending an email that contains iContact merge fields, you will see a notification 
on the iContact Send Message page that says, “This template has no merge fields.” This 
notification is a false negative and it’s something our developers will address in a future 
release of iContact for Salesforce. Despite the notification, you can confirm iContact merge 
fields by sending an email to your iContact for Salesforce Test Campaign.

2. Confirm your Contacts and Leads have data in the fields you’re merging. If there’s 
no data to merge, then iContact for Salesforce will merge a blank space in the email. 

3. Confirm the data is correct. iContact for Salesforce will merge the data you tell it to. If 
the data is wrong, then it will merge the wrong data.
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Run a report on Campaign Members
Running a report on Campaign Members is often the first step in advanced Campaign Member 
management. In addition to seeing which Contacts and Leads are members of a specific 
Campaign, you could run this report with the Member First Associated Date field to see when 
Contacts or Leads were first added to the Campaign, with the Total Value Opportunities field to 
measure the value of the opportunities associated with the Campaign, and so much more.

1. Click the Reports tab > New Report button.
2. Open the Campaigns folder > Campaigns With Campaign Members > Create 

button.
3. In the Filters section, change the Show drop down to Select A Campaign.
4. Click the Magnifying Glass icon and click the Campaign you’re interested in.
5. Click the Save button, give the report a name, then click the Save And Run Report 

button.
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Run a report on Contacts and Leads who 
never clicked a link
Run this report to target the Contacts or Leads who never clicked a link. You can add them to a 
re-engagement Campaign, get them to click through to your website, and convert.

1. Update statistics. For more information about updating statistics, see Chapter 9: 
Updating statistics.

2. Click the Reports tab.
3. Click the iContact Campaign Contacts / Leads folder on the left and click the 

iContact Campaign Contacts / Leads Clicked report on the right.
4. Click the Customize button.
5. In the Filters section, hover over the Last Clicked not equal to "" filter, and click Edit.
6. Change the operator to Equals, then click Ok.
7. In the Quick Find box in the Fields section on the left, type Created Date.
8. Drag the Created Date field listed under the iContact Message Statistics folder and 

drop it into the Preview section on the right.
9. Click the Save As button, give the report a name, then click Save And Run Report.
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Run a report on Contacts and Leads who 
never opened an email
Run this report to target the Contacts or Leads who never opened an email. You can add them 
to a re-engagement Campaign, get them to open and click through to your website, and convert.

1. Update statistics. For more information about updating statistics, see Chapter 9: 
Updating statistics.

2. Click the Reports tab.
3. Click the iContact Campaign Contacts / Leads folder on the left and click the 

iContact Campaign Contacts / Leads Opened report on the right.
4. Click the Customize button.
5. In the Filters section, hover over the Last Opened not equal to "" filter, and click Edit.
6. Change the operator to Equals, then click Ok.
7. In the Quick Find box in the Fields section on the left, type Created Date.
8. Drag the Created Date field listed under the iContact Message Statistics folder and 

drop it into the Preview section on the right.
9. Click the Save As button, give the report a name, then click Save And Run Report.
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Run a report on Contacts and Leads who 
received a specific email
If your Campaigns are routinely in a state of flux, you could run this report to see which Contacts 
and Leads received a specific email.

1. Update statistics. For more information about updating statistics, see Chapter 9: 
Updating statistics.

2. Click the Reports tab.
3. Click the iContact Campaign Contacts / Leads folder on the left and click the 

iContact Campaign Contacts and Leads report on the right.
4. Click the Hide Details button, check the box next to the Campaign you’re interested in, 

then click the Drill Down button at the bottom of the page.
5. Click the Show Details button 
6. Click the Customize button.
7. In the Filters section, click the triangle on the Add button and select Field Filter.
8. Type Subject in the first drop down and click iContact Sent Message: Message 

Subject (under iContact Message Statistics).
9. Change the operator to Equals.
10. Type the subject of the email you’re interested in into the text field, then click Ok.
11. Click the Save button, give the report a name, then click the Save And Run Report 

button.
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Run a report on Converted Leads
If you work with Leads, running this report will show you the number of Leads that were 
converted to Accounts due to your email marketing efforts.

1. Update statistics. For more information about updating statistics, see Chapter 9: 
Updating statistics.

2. Click the Reports Tab > New Report button.
3. Click Campaigns > Campaigns with Leads and Converted Lead Information > 

Create button.
4. In the Filter section, change the Show drop down to All Campaigns.
5. Click the Add button.
6. Change the Campaign Name drop down to Converted (in the Lead: General section).
7. Set the operator to Equals.
8. Click the Magnifying Glass icon and click True > Insert Selected > Ok.
9. Drag the Primary Campaign Source field from the Fields section on the left and drop it 

into the Preview section on the right.
10. Click the Save button, give the report a name, then click the Save And Run Report 

button.
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Run a report on iContact Sent Message 
Statistics
Running a report on iContact Sent Message Statistics gives you Campaign-level reporting with 
iContact for Salesforce data. In addition to seeing a list of emails sent to each Campaign, you 
could run this report with the Total Value Opportunities field to measure the value of the 
opportunities associated with the Campaign, with the Click Rate field to see the click rate 
percentage of each email, and so much more.

1. Update statistics. For more information about updating statistics, see Chapter 9: 
Updating statistics.

2. Click Setup > Create (under Build) > Report Types. Click the Continue button if 
necessary.

3. Click the Campaigns with iContact Sent Messages with iContact Message 
Statistics label.

4. Click the Clone button.
5. Give the report a new Report Type Label and Report Type Name, then click Save.
6. In the Object Relationships section, click the Edit button.
7. Click (Click to relate another object) and select iContact Clicked Links from the drop 

down, then click Save.
8. Click the Reports tab > New Report button.
9. Open the Campaigns folder > Click the report type you created > Create button.
10. In the Filters section, click the Magnifying Glass icon and select the Campaign you’re 

interested in.
11. Drag the fields you need from the Fields section on the left and drop them into the 

Preview section on the right.
12. Click the Save button, give the report a name, then click the Save And Run Report 

button.
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Run a report on opens sorted by email 
subject
If you send multiple emails to Campaigns, you can use this report to see which Contacts or 
Leads opened a specific email in a Campaign.

1. Update statistics. For more information about updating statistics, see Chapter 9: 
Updating statistics.

2. Click the Reports tab.
3. Click the iContact Campaign Contacts / Leads folder on the left and click the 

iContact Campaign Contacts / Leads Opened report on the right.
4. Click the Hide Details button, check the box next to the Campaign you’re interested in, 

then click the Drill Down button at the bottom of the page.
5. Click the Show Details button 
6. Click the Customize button.
7. In the Filters section, click the triangle on the Add button and select Field Filter.
8. Type Subject in the first drop down and click iContact Sent Message: Message 

Subject (under iContact Message Statistics).
9. Change the operator to Equals.
10. Type the subject of the email you’re interested in into the text field, then click Ok.
11. Click the Save button, give the report a name, then click the Save And Run Report 

button.
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Uninstall iContact for Salesforce

Note: You must be a Salesforce System Administrator to uninstall iContact for Salesforce.

Warning: Uninstalling iContact for Salesforce will delete all iContact for Salesforce Message 
Statistics data. Export and archive the data from your Salesforce account or from your 
bundled iContact account before uninstalling iContact for Salesforce.

1. Click Setup > Customize (under Build) > Campaigns > Page Layouts > Page Layout 
Assignment > Edit Assignment.

2. If the iContact for Salesforce record type is listed, click iContact for Salesforce, select 
Campaign Layout from the Page Layout To Use drop down, then click Save. If the 
iContact for Salesforce record type isn’t available, skip this step.

3. If you have Salesforce Professional edition, click Setup > (Customize under Build) > 
Campaigns > Page Layouts. Click Edit next to the Campaign Layout. Remove the 
iContact buttons, iContact Campaign Dashboard, and iContact Custom Links from 
the page layout. If you don’t have Salesforce Professional edition, skip this step.

4. Click Setup > Communication Templates (under Administer) > Email Templates.
5. Select the iContact Templates folder from the Folder drop down, then click the Edit 

link next to the drop down.
6. Move the folder’s templates from the Email Templates In This Folder section on the right 

to the Unfiled Public Email Templates section on the left, then click Save.
7. Click Setup > Installed Packages (under Build) > Uninstall (next to iContact for 

Salesforce).
8. At the bottom of the page, decide whether or not you want to save a copy of the iContact 

for Salesforce package after you uninstall, check Yes, I want to uninstall this package 
and permanently delete all associated components to confirm you want to uninstall 
iContact for Salesforce, then click Uninstall.

Note: These are the steps to uninstall iContact for Salesforce for most orgs. If your org or 
installation of iContact for Salesforce is customized, then you may need additional steps to 
uninstall. Salesforce may provide you with a list of components that are using iContact for 
Salesforce. If you see this list, navigate to the components Salesforce lists in the Components 
column, follow the instructions in the Problems column, then uninstall.
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Whitelisting iContact and updating your 
Sender Policy Framework (SPF) record
If your email is being delivered to your spam or junk folder or if it’s not being delivered at all, 
then we recommend whitelisting iContact and updating your SPF record. Whitelisting iContact 
approves the email we send for delivery on your incoming mail servers and updating your SPF 
record gives iContact permission to send email on behalf of your outgoing mail servers. 
Additionally, updating your SPF record has the added bonus of improving email deliverability for 
your subscribers.

Warning: Once an email is released from iContact, we have absolutely no control over it 
whatsoever. Our Deliverability team does everything they can to maintain a high inbox 
deliverability rating -- including managing DKIM, maintaining a good sending reputation with 
leading Email Service Providers, and policing our sending IPs for malicious senders -- but an 
email’s final destination is up to the receiving incoming mail server and its anti-spam settings. 
Whitelisting iContact and updating your SPF record will improve your inbox deliverability 
chances, but it will not guarantee inbox delivery.

iContact for Salesforce Support has not been trained to whitelist domains, to update your SPF 
record, or to troubleshoot problems with those tasks because doing so requires making 
changes to your domain’s DNS settings and incoming mail server settings. Please partner 
with an experienced IT Administrator and proceed with caution.

Whitelist the following domains

● app.icontact.com
● icontact.com
● icpbounce.com
● icptrack.com
● staticapp.icpsc.com

Recommended SPF record
v=spf1 a mx include:icpbounce.com ~all

Note: If you’re unable to define an SPF record with a domain, please contact Support for a list 
of IP addresses associated with your account.

mailto:salesforce@icontact.com?subject=SPF%2520record&body=I%2520can%2527t%2520define%2520an%2520SPF%2520record%2520with%2520a%2520domain%252E%2520Will%2520you%2520send%2520me%2520IP%2520addresses%253F
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D
Errors
Sooner or later you’ll encounter an error, but many errors can be resolved 
quickly and easily. This chapter outlines the most common errors and clear 
and simple steps to resolve them.

Most iContact for Salesforce errors are password-related, caused by routine password changes 
in Salesforce or by changing the bundled iContact account password without also changing the 
iContact API password. Other common errors are caused by setting up the wrong iContact 
Configuration page, by missing steps in the Installation Guide, and by poorly-formatted HTML.

In almost all cases errors are straightforward and easy to resolve.

The most important thing to know about errors is they stop the sending process. Which is to 
say, if you receive an error, your email will not be sent. Once the error is resolved, you must 
start the sending process again from the beginning.
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Attempt to de-reference a null object

Error: Attempt to de-reference a null object.

Error: System.NullPointerException: Attempt to de-reference a null object (Visualforce error).

Error: Attempt to de-reference a null object. Error in expression ‘{!sendMessage}’.

Note: You must be a Salesforce System Administrator to resolve this error.

Select your scenario
The error occurs when clicking the iContact Send button
The error occurs when clicking the Send To Campaign Members button
The Visualforce error occurs when clicking the Send To Campaign Members button
The error occurs when clicking the Update Statistics button

The error occurs when clicking the iContact Send button
This error is generated if the iContact Configurations page (plural), not the iContact 
Configuration page (singular), is configured; if the endpoint URL on the iContact Configuration 
page is incorrect; or if the API connection falls out of sync.

Remove the configuration from the iContact Configurations page

1. Click the + tab for all tabs.
2. Click iContact Configurations – the plural option with the computer icon.
3. Click the iContact configuration.
4. Copy the data in the Username, API Password, API AppID, Endpoint URL, Account ID, 

and Client Folder ID fields and paste it into another document like Notepad or Word or 
Pages. You’ll need them again in the next section.

5. Click the Delete button.

Configure the iContact Configuration page and sync the API connection

1. Click the + tab for all tabs.
2. Click iContact Configuration – the singular option with our logo.
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3. Click the Edit button.
4. Using the data you copied, complete the fields in the iContact API Connection section, 

then click Save.
5. In the Salesforce API Connection section, log in with your Salesforce System 

Administrator username and password.

The error occurs when clicking the Send To Campaign Members button

The template HTML may be corrupted. Please contact iContact for Salesforce Support. We 
can be reached at 1 (866) 331-3208, internationally at +1 (919) 926-4234, or via email at 
salesforce@icontact.com. We’re available Monday – Friday, 9 a.m. – 6 p.m. Eastern Time.

The Visualforce error occurs when clicking the Send To Campaign 
Members button
This error is generated when the user’s Profile doesn’t have the required Visualforce pages 
associated with it or if the user is trying to send the email without enabling mixed content in 
Internet Explorer 9.

Assign the required Visualforce pages to the user’s Profile

1. Click Setup > Manage Users (under Administer) > Users.
2. Locate the user’s name, click the name, then click the Profile link.
3. Click the Enabled Visualforce Page Access link at the top of the page, then click Edit.
4. Enable every Visualforce page that starts with the iContactforSF prefix, then click 

Save.
5. Click the + tab for all tabs.
6. Click iContact Configuration – the singular option with our logo.
7. In the Salesforce API Connection section, log in with your Salesforce System 

Administrator username and password.

Allow mixed content in Internet Explorer

1. Click Tools > Internet Options > Security > Custom Level.
2. In the Miscellaneous section, click Display Mixed Content > Enable.

mailto:salesforce@icontact.com
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The error occurs when clicking the Update Statistics button
This error is generated when the API connection falls out of sync or if the user doesn’t have the 
required permissions to update statistics.

Sync the API connection

1. Click the + tab for all tabs.
2. Click iContact Configuration – the singular option with our logo.
3. In the Salesforce API Connection section, log in with your Salesforce System 

Administrator username and password.

Check the permissions for the user’s profile

1. Click Setup > Manage Users (under Administer) > Users.
2. Locate the user’s name, click the name, then click the Profile link.
3. Click the Edit button.
4. In the Standard Object Permissions section, at a minimum, set Campaigns, Contacts, 

and Leads to Read, Create, and Edit.
5. In the Custom Object Permissions section, at a minimum, set iContact Clicked Links, 

iContact Global Statistics, and iContact Message Statistics to Read and Create, 
then click Save.
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Email status is stuck as “Scheduled” or
“In Progress”
If an email takes longer than expected to be sent, there’s a chance the API window between 
iContact and Salesforce will close before iContact updates Salesforce with the status of the 
send. In most cases, regardless of the status, the email is sent without any trouble at all.

Verify whether or not the email was sent

1. Click the iContact MessageBuilder tab or log in to iContact directly .
2. In iContact, click Reports > Sent Messages. If the email is listed on the Track Sent 

Messages page, then it was sent. If the email is not listed, then it was not sent.

If the email was sent, update the email status in Salesforce

1. Click the Campaigns tab.
2. Click the Campaign that contains the email that’s stuck.
3. Click the iContact Sent Messages link.
4. Click the Edit link next to the email that’s stuck.
5. Change the Status to Released.
6. Click Save.

If the email was not sent, please contact iContact for Salesforce Support. We can be reached 
at 1 (866) 331-3208, internationally at +1 (919) 926-4234, or via email at 
salesforce@icontact.com. We’re available Monday – Friday, 9 a.m. – 6 p.m. Eastern Time.

https://www.icontact.com/login
mailto:salesforce@icontact.com
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Field accessibility

Error: Field accessibility is not properly assigned for one or more of the fields required by 
iContact for Salesforce.

Note: You must be a Salesforce System Administrator to resolve this error.

Select your scenario
I’m using Salesforce Enterprise or Unlimited edition
I’m using Salesforce Professional or Professional Plus edition

Salesforce Enterprise or Unlimited edition
This error is generated when one or more fields required by iContact for Salesforce are hidden 
or inaccessible.

Configure the field accessibility for the Contact and Lead objects

1. Click Setup > Security Controls (under Administer) > Field Accessibility > Contact.
2. Click View By Profiles and select the System Administrator Profile from the drop 

down.
3. Check that the Field Access for the fields listed below is Editable or Required. If not, 

click Hidden. In the Field-Level Security section, set the Profile to Visible; in the Page 
Layout section, set the Page Layout to Visible; then click Save.

○ Email
○ Email Opt Out
○ Fax
○ iContact Contact ID
○ Mailing Address (for Contacts) / Address (for Leads)
○ Name
○ Phone

Note: You may not use all of these fields, but they’re all required for iContact for Salesforce to 
work.
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4. Repeat Steps 2 - 3 for the Marketing User profile as well as any other profiles that have 
access to iContact for Salesforce.

5. Click Field Accessibility > Lead and repeat Steps 2 - 4 for the Lead object.

Salesforce Professional or Professional Plus edition
This error is generated when one or more fields required by iContact for Salesforce is not 
associated with an iContact for Salesforce page layout or is hidden or inaccessible.

Configure the Contact and Lead page layout

1. Click Setup > Customize (under Build) > Contacts > Page Layout.
2. In the purple and gray box, click Fields.
3. Drag and drop the fields listed below onto the Contact Page Layout:

○ Email
○ Email Opt Out
○ Fax
○ iContact Contact ID
○ Mailing Address (for Contacts) / Address (for Leads)
○ Name
○ Phone

Note: You may not use all of these fields, but they’re all required for iContact for Salesforce to 
work.

4. After adding the iContact Contact ID field, mouse over it and click the wrench icon, 
check the Read-Only box, then click Ok.

5. In the purple and gray box, click Related Lists.
6. Drag and drop the iContact Message Statistic and iContact Clicked Links lists onto 

the Contact Page Layout.
7. Click the wrench icon on the iContact Message Statistic list. Move the following fields 

from the Available Fields on the left to the Selected Fields on the right:

○ Recipient Name
○ Campaign
○ iContact Sent Message
○ Total Opens
○ Total Clicks
○ Bounced Date
○ Unsubscribed Date
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○ Created Date

8. Change the Sort By drop down to Created Date and select the Descending option.
9. Expand the purple Buttons section and uncheck the New box, then click Ok.
10. Click the wrench icon on the iContact Clicked Links list. Move the following fields from 

the Available Fields on the left to the Selected Fields on the right:

○ Link
○ Full Link
○ Clicks
○ Unique Clicks
○ Created Date

11. Change the Sort By drop down to Created Date and select the Descending option.
12. Expand the purple Buttons section and uncheck the New box, click Ok, then click Save 

on the purple and gray box at the top of the page.
13. Repeat this section from Step 1 for the Lead Page Layout, click Setup > Customize 

(under Build) > Leads > Page Layout.

Note: Even if you don’t use both the Contact and Lead objects, they’re both required for 
iContact for Salesforce to work.

Configure the iContact Sent Message and iContact Message Statistic page layouts

1. Click Setup > Create (under Build) > Objects > iContact Sent Message.
2. In the Page Layouts section, click the Edit link next to iContact Sent Message Layout.
3. In the purple and gray box, click Fields.
4. Drag and drop the following fields onto the Page Layout:

○ Comments
○ iContact Asynchronous Send ID
○ iContact Campaign ID
○ iContact Message ID
○ iContact Send ID
○ IdString
○ Status Summary

5. In the purple and gray box, click Save.
6. Click Setup > Create (under Build) > Objects > iContact Message Statistic.
7. In the Page Layouts section, click the Edit link next to iContact Message Statistic 

Layout.
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8. In the purple and gray box, click Fields.
9. Drag and drop the following field onto the Page Layout:

○ iContact Contact ID

10. In the purple and gray box, click Save.

Configure the field accessibility for the Contact and Lead objects

1. Click Setup > Security Controls (under Administer) > Field Accessibility > Contact.
2. Click View By Profiles and select the System Administrator Profile from the drop 

down.
3. Check that the Field Access for the fields listed below is Editable or Required. If not, 

click Hidden. In the Field-Level Security section, set the Profile to Visible; in the Page 
Layout section, set the Page Layout to Visible; then click Save.

○ Email
○ Email Opt Out
○ Fax
○ iContact Contact ID
○ Mailing Address (for Contacts) / Address (for Leads)
○ Name
○ Phone

Note: You may not use all of these fields, but they’re all required for iContact for Salesforce to 
work.

4. Repeat Steps 2 - 3 for the Marketing User profile as well as any other profiles that have 
access to iContact for Salesforce.

5. Click Field Accessibility > Lead and repeat Steps 2 - 4 for the Lead object.
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iContact login page
iContact for Salesforce is designed to seamlessly log you in to your bundled iContact account 
whenever you click the iContact MessageBuilder tab or the iContact Configuration tab. We’re 
able to do this if your iContact account password matches your iContact API password. If you 
ever encounter an iContact login screen, someone changed the iContact account password 
without updating the iContact API password to match.

Note: You must be a Salesforce System Administrator to set the new passwords.

Update your iContact API password to match your iContact account password

1. Login to iContact in an alternate browser . If you usually work in Firefox, open 
Chrome. If you usually work in Chrome, open Firefox.

2. Click the Account drop down > User Settings. The Account drop down displays your 
name or a colleague’s name.

3. Temporarily change your preferred password to something easy to remember, like your 
mom’s nickname and birth year.

4. Paste the following into the URL bar:

https://app.icontact.com/icp/core/registerapp

5. In the API 2.0 Authentication section, click Change your API password for this AppId.
6. In the Change Password For iContact for Salesforce section, type your preferred 

password into the Create A Password box, then click Save.
7. Click the Account drop down > User Settings.

https://www.icontact.com/login
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8. Change the iContact account password from the temporary password to your preferred 
password. The iContact account password and the iContact API password should now 
be the same.

9. Sign out of iContact and close your alternate browser.

Update the iContact API password in Salesforce and sync the API connection

1. Log in to Salesforce in your primary browser.
2. Click the + tab for all tabs.
3. Click iContact Configuration – the singular option with our logo.
4. Click the Edit button.
5. Update the API Password box with your preferred password, then click Save.
6. In the Salesforce API Connection section, log in with your Salesforce System 

Administrator username and password.
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Insufficient access / privileges

Error: Insufficient Access.

Error: Insufficient Privileges.

Note: You must be a Salesforce System Administrator to resolve this error.

1. Click Setup > Manage Users (under Administer) > Users.
2. Locate the user who experienced the error and click their name.
3. Click the Edit button.
4. Check the Marketing User box in the right column of the General Information section, 

then click Save.
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Invalid credentials

Error: Your Salesforce API credentials are invalid. Please resubmit.

Note: You must be a Salesforce System Administrator to resolve this error.

By default, Salesforce requires a password change every 90 days. When the admin who gave 
iContact permission to access your org updates his or her password, the API connection falls 
out of sync because the old password is no longer valid.

Sync the API connection

1. Click the + tab for all tabs.
2. Click iContact Configuration – the singular option with our logo.
3. In the Salesforce API Connection section, log in with your Salesforce System 

Administrator username and password.
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List has no rows for assignment to SObject

Error: List has no rows for assignment to SObject.

Note: You must be a Salesforce System Administrator to resolve this error.

Select your scenario
The error occurs when clicking the iContact Send button
The error occurs when clicking the Send To Campaign Members button

The error occurs when clicking the iContact Send button
This error is generated if the iContact Configurations page (plural), not the iContact 
Configuration page (singular), is configured.

Remove the configuration from the iContact Configurations page

1. Click the + tab for all tabs.
2. Click iContact Configurations – the plural option with the computer icon.
3. Click the iContact configuration.
4. Copy the data in the Username, API Password, API AppID, Endpoint URL, Account ID, 

and Client Folder ID fields and paste it into another document like Notepad or Word or 
Pages. You’ll need them again in the next section.

5. Click the Delete button.

Configure the iContact Configuration page and sync the API connection

1. Click the + tab for all tabs.
2. Click iContact Configuration – the singular option with our logo.
3. Click the Edit button.
4. Using the data you copied, complete the fields in the iContact API Connection section, 

then click Save.
5. In the Salesforce API Connection section, log in with your Salesforce System 

Administrator username and password.
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The error occurs when clicking the Send To Campaign Members button

Please contact iContact for Salesforce Support. We can be reached at 1 (866) 331-3208, 
internationally at +1 (919) 926-4234, or via email at salesforce@icontact.com. We’re available 
Monday – Friday, 9 a.m. – 6 p.m. Eastern Time.

mailto:salesforce@icontact.com
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List index out of bounds

Error: List index out of bounds: 0

Note: You must be a Salesforce System Administrator to resolve this error.

Select your scenario
The error occurs when clicking the iContact Send button
The error occurs when clicking the Send To Campaign Members button

The error occurs when clicking the iContact Send button
This error is generated if the iContact Configurations page (plural), not the iContact 
Configuration page (singular), is configured; if the default email folder doesn’t contain at least 
one template that was made available for use; or if the email folder you’re trying to access is 
managed by group sharing rules.

Remove the configuration from the iContact Configurations page

1. Click the + tab for all tabs.
2. Click iContact Configurations – the plural option with the computer icon.
3. Click the iContact configuration.
4. Copy the data in the Username, API Password, API AppID, Endpoint URL, Account ID, 

and Client Folder ID fields and paste it into another document like Notepad or Word or 
Pages. You’ll need them again in the next section.

5. Click the Delete button.

Configure the iContact Configuration page and sync the API connection

1. Click the + tab for all tabs.
2. Click iContact Configuration – the singular option with our logo.
3. Click the Edit button.
4. Using the data you copied, complete the fields in the iContact API Connection section, 

then click Save.
5. In the Salesforce API Connection section, log in with your Salesforce System 

Administrator username and password.
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Confirm that the email folder is accessible by all users and that it contains at least one 
template that was made available for use

1. Click Setup > Communication Templates (under Administer) > Email Templates.
2. In the Folder drop down, select the folder that contains the template you’re trying to 

send.
3. Click the Edit link next to the Folder drop down.
4. Click This folder is accessible by all users, then click Save.
5. Confirm that the template you want to send was marked as available for use. If not, click 

the Edit link next to the template, check the Available For Use box, then click Save.

If the error persists, the template HTML may be corrupted. Please contact iContact for 
Salesforce Support. We can be reached at 1 (866) 331-3208, internationally at
+1 (919) 926-4234, or via email at salesforce@icontact.com. We’re available Monday – 
Friday, 9 a.m. – 6 p.m. Eastern Time.

The error occurs when clicking the Send To Campaign Members button
This error is generated when the API connection falls out of sync, by an ampersand in the From 
Name, or by a fully spelled-out State name.

Sync the API connection

1. Click the + tab for all tabs.
2. Click iContact Configuration – the singular option with our logo.
3. In the Salesforce API Connection section, log in with your Salesforce System 

Administrator username and password.

Confirm the Sending Option

1. Check the From Name field. If there is an ampersand (&), replace it with the word “and.”
2. Check the State field. If the state is spelled-out, replace it with the state’s two-letter 

abbreviation.

If the error persists, the template HTML may be corrupted. Please contact iContact for 
Salesforce Support. We can be reached at 1 (866) 331-3208, internationally at
+1 (919) 926-4234, or via email at salesforce@icontact.com. We’re available Monday – 
Friday, 9 a.m. – 6 p.m. Eastern Time.

mailto:salesforce@icontact.com
mailto:salesforce@icontact.com
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Missing Add To Campaign button
Salesforce does not support the Add To Campaign button on every report. The only reports that 
support the Add To Campaign button are standard Account And Contact, Opportunities And 
Roles, Cases And Roles, and Lead reports. Salesforce does not support the Add To Campaign 
button on reports that include Custom Objects like the iContact Message Statistics or iContact 
Sent Messages objects, nor does it support the button on reports that contain both Contacts and 
Leads.

If you run a report that does not support the Add To Campaign button, you can export the report 
to a .csv and upload it directly to your Campaign.

Upload Campaign Members from a .csv

1. Confirm that the report contains the Lead/Contact ID and Email fields. If not, customize 
the report to include the Lead/Contact ID and Email fields.

Note: The Lead ID and Contact ID are referred to as the Salesforce.com ID in the Data Import 
Wizard in the steps that follow.

2. Click the Run Report button > Export Details button.
3. Change the Export File Format to Comma Delimited .csv, then click Export.
4. Click the Campaigns tab > Click your Campaign.
5. Click the Manage Members button > Add Members - Import File.
6. Follow the steps listed in the Data Import Wizard. Salesforce will send you an email 

when the upload is completed.

For more information about using the Data Import Wizard, see Salesforce’s Data Import
Series . For more information about importing Campaign Members, see Importing Campaign 
Members  in the Salesforce Success Community.

http://salesforce.vidyard.com/watch/ARIjWm2qrDkJVJxEhReFug
http://salesforce.vidyard.com/watch/ARIjWm2qrDkJVJxEhReFug
https://help.salesforce.com/HTViewHelpDoc?id=campaigns_import.htm&language=en_US
https://help.salesforce.com/HTViewHelpDoc?id=campaigns_import.htm&language=en_US
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Missing template folder
To help reduce clutter, template folders disappear from iContact for Salesforce if they aren’t 
accessible by all users in your org and if they don’t contain at least one template that was 
marked as available for use.

Display missing template folders

1. Click Setup > Communication Templates (under Administer) > Email Templates.
2. Select the missing template folder from the Folder drop down.
3. Click the Edit link next to the Folder drop down.
4. Click This folder is accessible by all users, then click Save.
5. Confirm the folder contains at least one template that was marked as available for use. If 

not, click the Edit link next to any template, check the Available For Use box, then 
click Save.
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Mixed Content
The iContact MessageBuilder tab or Help tab is blank
The Salesforce API Connection section is blank
The Send To Campaign Members button isn’t working

These three different issues have one root cause: mixed content. Mixed content occurs when 
you’re attempting to load content of varying levels of security onto a page. iContact meets 
Salesforce’s security standards, but Salesforce is more secure than iContact. If nothing 
happens when you’re trying to load the iContact MessageBuilder tab or Help tab, sync the API 
connection, or send an email, your browser is blocking mixed content.

Allow mixed content in Chrome

1. Click the gray shield on the right side of the URL bar.
2. Click Load unsafe scripts.

Allow mixed content in Firefox

1. Click the green lock on the left side of the URL bar.
2. Click the arrow on the right side of the pop-up, then click Disable Protection For Now.

Allow mixed content in Internet Explorer

1. Click Tools > Internet Options > Security > Custom Level.
2. In the Miscellaneous section, click Display Mixed Content > Enable.

You can not allow mixed content in Safari
If you’re using Safari 8 or later, Apple has not yet provided a way to allow mixed content. We 
suggest downloading Chrome  or Firefox  and using one of those browsers instead.

https://www.google.com/chrome/browser/desktop/
https://www.mozilla.org/en-US/firefox/new/
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No valid recipients

Error: There are no valid recipients in this Campaign.

Error: The Targeted Send options you selected contain no recipients. Please try again.

Note: You must be a Salesforce System Administrator to resolve this error.

Are you trying to send email from a Sandbox?
Sending is disabled in Sandbox environments and may result in the “No valid recipients” error. If 
you’re working in a Sandbox, install iContact for Salesforce in your production environment and 
try sending again.

Have you recently changed your Salesforce password?
By default, Salesforce requires a password change every 90 days. When the user who gave 
iContact permission to access your Salesforce org updates his or her password, the API 
connection falls out of sync because the old password is no longer valid.

Sync the API connection

1. In Salesforce, click the + tab for all tabs.
2. Click iContact Configuration – the singular option with our logo.
3. In the Salesforce API Connection, log in with your Salesforce System Administrator 

username and password.
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Are your Campaign Members Contacts or Leads?
iContact for Salesforce sends email to Contacts and Leads only.

Do your Contacts or Leads have an email address in the standard Salesforce Email field?
iContact for Salesforce can only send email to Contacts or Leads who have an email address in 
the standard Salesforce Email field.

Is the Email Opt Out box checked for every Contact or Lead in the Campaign?
iContact for Salesforce can’t send email to Contacts or Leads who have opted out of receiving 
your email. 

Has every Contact or Lead bounced from a previous send?
iContact for Salesforce can send email to Campaign Members who are subscribed to your 
account and who are not in a bounced status. Confirm the deliverability status of your Campaign 
Members in your bundled iContact account.

1. Copy the email address of a Contact or Lead in the Campaign.
2. Click the iContact MessageBuilder tab or log in to iContact directly .
3. Click Contacts > Search Contacts.
4. Paste the email address in the Quick Search box, then click Quick Search.

Note: The information above the table tells you whether the Contact or Lead is in a bounced 
status or if they unsubscribed from your account. You can click Manage Contact > View 
History to see when a Contact or Lead bounced or unsubscribed.

Are you trying to send a Targeted Send based on an email that was originally sent using 
iContact for Salesforce Lite?
Because iContact for Salesforce doesn’t track data at the Contact or Lead level when you send 
email using iContact for Salesforce Lite, the Targeted Send functionality is lost. For more 
information about Targeted Sends, see Chapter 10: Sending a Targeted Send.

Was the email sent using the normal version of iContact for Salesforce that tracks clicks 
for individuals and are you trying to send a Targeted Send to Contacts or Leads who 
clicked a specific link in an email?

Please contact iContact for Salesforce Support. We can be reached at 1 (866) 331-3208, 
internationally at +1 (919) 926-4234, or via email at salesforce@icontact.com. We’re available 
Monday – Friday, 9 a.m. – 6 p.m. Eastern Time.

https://www.icontact.com/login
mailto:salesforce@icontact.com
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Null

Error: Null

Note: You must be a Salesforce System Administrator to set the new passwords.

This error is generated by a past-due balance on your bundled iContact account, by a mismatch 
between your bundled iContact account password and your iContact API password, or by 
exceeding the Salesforce API limit or data storage limit.

Is there a past-due balance on your bundled iContact account?

1. Click the iContact MessageBuilder tab or log in to iContact directly .
2. Click the Account drop down > Invoices And Receipts. The Account drop down 

displays your name or a colleague’s name.

Outstanding invoices will be listed in red. Partner with your Finance team to make payment.

Did you change your bundled iContact account password?
iContact for Salesforce is designed to seamlessly log you in to your bundled iContact account 
when necessary. We’re able to do this if your iContact account password matches your iContact 
API password. If your iContact account password was changed and the iContact API password 
wasn’t updated to match, then you may encounter a Null error.

Update your iContact API password to match your iContact account password

1. Login to iContact in an alternate browser . If you usually work in Firefox, open 
Chrome. If you usually work in Chrome, open Firefox.

2. Click the Account drop down > User Settings. The Account drop down displays your 
name or a colleague’s name.

3. Temporarily change your preferred password to something easy to remember, like your 
mom’s nickname and birth year.

4. Paste the following into the URL bar:

https://app.icontact.com/icp/core/registerapp

https://www.icontact.com/login
https://www.icontact.com/login
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5. In the API 2.0 Authentication section, click Change your API password for this AppId.
6. In the Change Password For iContact for Salesforce section, type your preferred 

password into the Create A Password box, then click Save.
7. Click the Account drop down > User Settings.
8. Change the iContact account password from the temporary password to your preferred 

password. The iContact account password and the iContact API password should now 
be the same.

9. Sign out of iContact and close your alternate browser.

Update the iContact API password in Salesforce and sync the API connection

1. Log in to Salesforce in your primary browser.
2. Click the + tab for all tabs.
3. Click iContact Configuration – the singular option with our logo.
4. Click the Edit button.
5. Update the API Password box with your preferred password, then click Save.
6. In the Salesforce API Connection section, log in with your Salesforce System 

Administrator username and password.

Have you exceeded the Salesforce API or Salesforce data storage limit?

1. Click Setup > System Overview (under Monitor).

If the API Usage box or Data Storage section in the Schema box is red, then you have 
exceeded one or both of the limits.

If you exceeded the API usage limit, then you must wait for the API usage limit to reset 
automatically or contact Salesforce Support and request a manual reset. Salesforce Support 
can be reached at 1 (800) 667-6389, online at help.salesforce.com , or by email at 
supportresponse@salesforce.com.

If you exceeded the data storage limit, then you must purchase more storage from Salesforce or 
delete data from your org. For more information about deleting iContact Message Statistics, see 
Delete iContact Message Statistics data.

Password is not recognized

Error: The password you provided is not recognized.

https://help.salesforce.com/
mailto:supportresponse@salesforce.com
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Note: You must be a Salesforce System Administrator to resolve this error.

This error is generated by a mismatch between your bundled iContact account password and 
your iContact API password or by trying to send an email from a Sandbox.

Update your iContact API password to match your iContact account password

1. Login to iContact in an alternate browser . If you usually work in Firefox, open 
Chrome. If you usually work in Chrome, open Firefox.

2. Click the Account drop down > User Settings. The Account drop down displays your 
name or a colleague’s name.

3. Temporarily change your preferred password to something easy to remember, like your 
mom’s nickname and birth year.

4. Paste the following into the URL bar:

https://app.icontact.com/icp/core/registerapp

5. In the API 2.0 Authentication section, click Change your API password for this AppId.
6. In the Change Password For iContact for Salesforce section, type your preferred 

password into the Create A Password box, then click Save.
7. Click the Account drop down > User Settings.
8. Change the iContact account password from the temporary password to your preferred 

password. The iContact account password and the iContact API password should now 
be the same.

9. Sign out of iContact and close your alternate browser.

Update the iContact API password in Salesforce and sync the API connection

1. Log in to Salesforce in your primary browser.
2. Click the + tab for all tabs.
3. Click iContact Configuration – the singular option with our logo.
4. Click the Edit button.
5. Update the API Password box with your preferred password, then click Save.
6. In the Salesforce API Connection section, log in with your Salesforce System 

Administrator username and password.

iContact for Salesforce and Sandbox
Sending is disabled in Sandbox environments and may result in the “Password is not 
recognized” error. If you’re working in a Sandbox, install iContact for Salesforce in your 
production environment and try sending again.

https://www.icontact.com/login
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Session has timed out
If you click the iContact MessageBuilder tab and find your session has timed out, follow these 
steps to easily log in without typing a single keystroke.

1. Click the + tab for all tabs.
2. Click iContact Configuration – the singular option with our logo.
3. Click the iContact MessageBuilder tab.
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Unable to cancel email

Error: The iContact Message ID is currently not available to cancel the send. Please try 
again.

This error is generated when you attempt to cancel an email that’s too far along in the sending 
process to be canceled from Salesforce. Follow these steps to attempt to cancel the email from 
your bundled iContact account. 

1. Click the iContact MessageBuilder tab or log in to iContact directly .
2. Click Email > Pending Messages > Cancel This Message.

For more information about canceling email, see Chapter 8: Canceling email.

https://www.icontact.com/login
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Unable to sync the API connection
Syncing the API connection should be as easy as typing your password and clicking Submit. 
Should you ever run into trouble, follow these steps to get back up and running.

1. Confirm that you’re using the correct Salesforce username and password combination 
by logging out of Salesforce and logging in again by typing your username and 
password.

2. If you log in to Salesforce at a custom domain, confirm that you added the custom 
domain to the Salesforce API Connection section.

3. If you use a security token when you log in to Salesforce, confirm that you’re using your 
security token to sync the API connection.

4. If you use Single Sign-On or a password manager, it may be auto-populating the 
password field with an old password. Temporarily disable Single Sign-On or your 
password manager and try again.

5. Partner with another System Administrator in your org and try syncing the API 
connection with his or her Salesforce credentials.

6. Confirm that iContact’s IP ranges are trusted by your org and that your session isn’t 
locked to an IP address.

a. Click Setup > Security Controls (under Administer) > Network Access.
b. Check that the following Trusted IP Ranges are listed. If necessary, click the 

New button to add them.

66.192.165.133 - 66.192.165.133
69.166.132.241 - 69.166.132.254
69.166.134.129 - 69.166.134.158

c. Click Security Controls (under Administer) > Session Settings.
d. In the Session Settings section, uncheck Lock sessions to the IP address from 

which they originated.

7. Confirm that you haven’t exceeded your API limit in Salesforce.

a. Click Setup > System Overview (under Monitor).

If the API Usage box is red, then you have exceeded the limit. You must wait for 
the API usage limit to reset automatically or contact Salesforce Support and 
request a manual reset. Salesforce Support can be reached at 1 (800) 667-6389, 
online at help.salesforce.com , or by email at 

https://help.salesforce.com/
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supportresponse@salesforce.com.

8. Confirm your firewall isn’t blocking iContact.

a. Click Setup > Manage Users (under Administer) > Users > click your name > 
Login History link.

If the Source IP for the iContact/Corp/ Application is Restricted, then your firewall 
is blocking iContact. Please partner with your IT team for further assistance.

mailto:supportresponse@salesforce.com
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Unable to validate merge fields

Error: Unfortunately, we encountered a problem when attempting to validate the merge fields 
for this template.

Note: You must be a Salesforce System Administrator to resolve this error.

By default, Salesforce requires a password change every 90 days. When the user who gave 
iContact permission to access your Salesforce org updates his or her password, the API 
connection falls out of sync because the old password is no longer valid.

Sync the API connection

1. Click the + tab for all tabs.
2. Click iContact Configuration – the singular option with our logo.
3. In the Salesforce API Connection section, log in with your Salesforce System 

Administrator username and password.
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Unknown error

Error: Unknown error.

Note: You may need to be the iContact Account Administrator or a Salesforce System 
Administrator to resolve this error.

This error is generated by a mismatch between your bundled iContact account password and 
your iContact API password, by the API connection falling out of sync, by a past-due balance on 
your bundled iContact account, or by a Deliverability issue.

Did you change your bundled iContact account password?
iContact for Salesforce is designed to seamlessly log you in to your bundled iContact account 
when necessary. We’re able to do this if your iContact account password matches your iContact 
API password. If your iContact account password was changed and the iContact API password 
wasn’t updated to match, then you may encounter an Unknown error.

Update your iContact API password to match your iContact account password

1. Login to iContact in an alternate browser . If you usually work in Firefox, open 
Chrome. If you usually work in Chrome, open Firefox.

2. Click the Account drop down > User Settings. The Account drop down displays your 
name or a colleague’s name.

3. Temporarily change your preferred password to something easy to remember, like your 
mom’s nickname and birth year.

4. Paste the following into the URL bar:

https://app.icontact.com/icp/core/registerapp

5. In the API 2.0 Authentication section, click Change your API password for this AppId.
6. In the Change Password For iContact for Salesforce section, type your preferred 

password into the Create A Password box, then click Save.
7. Click the Account drop down > User Settings.
8. Change the iContact account password from the temporary password to your preferred 

password. The iContact account password and the iContact API password should now 
be the same.

9. Sign out of iContact and close your alternate browser.

https://www.icontact.com/login
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Update the iContact API password in Salesforce and sync the API connection

1. Log in to Salesforce in your primary browser.
2. Click the + tab for all tabs.
3. Click iContact Configuration – the singular option with our logo.
4. Click the Edit button.
5. Update the API Password box with your preferred password, then click Save.
6. In the Salesforce API Connection section, log in with your Salesforce System 

Administrator username and password.

Is there a past-due balance on your bundled iContact account?

1. Click the iContact MessageBuilder tab or log in to iContact directly .
2. Click the Account drop down > Invoices And Receipts. The Account drop down 

displays your name or a colleague’s name.

Outstanding invoices will be listed in red. Partner with your Finance team to make payment.

Resolve any Deliverability issues
If you received an email from our Deliverability team regarding your bundled iContact account, 
partner with them and confirm your account is still in good standing.

iContact Deliverability can be reached at 1 (888) 538-5590, internationally at +1 (919) 957-6070, 
by email at deliverability@icontact.com, or by chat at iContact.com . iContact Deliverability 
hours are Monday - Friday, 8 a.m. - 8 p.m. Eastern Time.

https://www.icontact.com/login
mailto:deliverability@icontact.com
https://www.icontact.com/support
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E
Support
Help is never more than a click or call away.

iContact Help Portal
We wrote hundreds of articles to help you get the most out of iContact for Salesforce and your 
bundled iContact account. Available 24 hours a day, 7 days a week, the iContact Help Portal is 
a great resource for resolving common errors, tutorials, and more.
Knowledge is power 

iContact for Salesforce Support
Reach out to iContact for Salesforce Support for iContact for Salesforce-specific questions. For 
example, questions about your bundled iContact account, billing, or getting additional help with 
anything outlined in our Help articles.

iContact for Salesforce Support can be reached at 1 (866) 331-3208, internationally at
+1 (919) 926-4234, or by email at salesforce@icontact.com. iContact for Salesforce Support 
hours are Monday - Friday, 9 a.m. - 6 p.m. Eastern Time.

iContact Deliverability
Reach out to iContact Deliverability if you have questions about reducing bounces, list cleaning 
services, or if sending is disabled for your account.

iContact Deliverability can be reached at 1 (888) 538-5590, internationally at +1 (919) 957-6070, 
by email at deliverability@icontact.com, or by chat at iContact.com . iContact Deliverability 
hours are Monday - Friday, 8 a.m. - 8 p.m. Eastern Time.

iContact Sales

https://app.icontact.com/icp/core/help/en-us/search
mailto:salesforce@icontact.com
mailto:deliverability@icontact.com
https://www.icontact.com/support
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Reach out to iContact Sales if you wish to upgrade your account.

iContact Sales can be reached at 1 (877) 820-7837, internationally at +1 (919) 957-6150, or by 
email at sales@icontact.com. iContact Sales hours are Monday - Friday, 9 a.m. - 6 p.m. Eastern 
Time.

iContact Design Services
Reach out to iContact Design Services if you need to make big changes to your HTML 
templates. For example, adding or moving sections or columns, customizing code you built, or 
designing a custom template.

iContact Design Services can be reached by email at designservices@icontact.com. iContact 
Design Services hours are Monday - Friday, 8 a.m. - 6 p.m. Eastern Time.

Salesforce Support
Reach out to Salesforce Support for all Salesforce-specific questions that fall outside the scope 
of our support. For example, errors adding Campaign Members, difficulty building reports, or 
workflows.

Salesforce Support can be reached at 1 (800) 667-6389, online at help.salesforce.com , or by 
email at supportresponse@salesforce.com.

mailto:sales@icontact.com
mailto:designservices@icontact.com
https://help.salesforce.com/home
mailto:supportresponse@salesforce.com

